summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-15 02:47:46 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-15 02:47:46 +0000
commitc6f58c945c3fc223ce604b6c13f753cdf3ec3913 (patch)
tree0018916b4a61fb4493479c25a912d1bb458c7f15
parentStable x86 and amd64. (diff)
downloadhistorical-c6f58c945c3fc223ce604b6c13f753cdf3ec3913.tar.gz
historical-c6f58c945c3fc223ce604b6c13f753cdf3ec3913.tar.bz2
historical-c6f58c945c3fc223ce604b6c13f753cdf3ec3913.zip
Fix use invocation, make use of use_enable, clean up ebuild
-rw-r--r--net-print/omni/ChangeLog5
-rw-r--r--net-print/omni/Manifest4
-rw-r--r--net-print/omni/omni-0.9.0.ebuild41
-rw-r--r--net-print/pdq/Manifest4
4 files changed, 23 insertions, 31 deletions
diff --git a/net-print/omni/ChangeLog b/net-print/omni/ChangeLog
index c935697e4bcf..d2da4c2100a9 100644
--- a/net-print/omni/ChangeLog
+++ b/net-print/omni/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-print/omni
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/omni/ChangeLog,v 1.4 2004/03/02 14:07:32 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/omni/ChangeLog,v 1.5 2004/06/15 02:47:46 agriffis Exp $
+
+ 14 Jun 2004; Aron Griffis <agriffis@gentoo.org> omni-0.9.0.ebuild:
+ Fix use invocation, make use of use_enable, clean up ebuild
02 Mar 2004; Heinrich Wendel <lanius@gentoo.org> omni-0.9.0.ebuild:
sed -i
diff --git a/net-print/omni/Manifest b/net-print/omni/Manifest
index 1fee89578720..66b97aeb2a86 100644
--- a/net-print/omni/Manifest
+++ b/net-print/omni/Manifest
@@ -1,4 +1,4 @@
-MD5 dfcb433bd773cedb31b0beafc1b5473b omni-0.9.0.ebuild 1500
-MD5 6a799c4df301656ab559540ed0bb4a48 ChangeLog 653
+MD5 230c3b98f3ce54d4ffa6d5e2d89676e6 omni-0.9.0.ebuild 1275
+MD5 3383f7a2e59cf4ba700adf0ad5107313 ChangeLog 786
MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
MD5 a0f001bbeec0ec15dff8fac7e9790527 files/digest-omni-0.9.0 63
diff --git a/net-print/omni/omni-0.9.0.ebuild b/net-print/omni/omni-0.9.0.ebuild
index ce1f23235ec2..6be06024fb8d 100644
--- a/net-print/omni/omni-0.9.0.ebuild
+++ b/net-print/omni/omni-0.9.0.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-print/omni/omni-0.9.0.ebuild,v 1.6 2004/03/02 14:07:32 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/omni/omni-0.9.0.ebuild,v 1.7 2004/06/15 02:47:46 agriffis Exp $
DESCRIPTION="Omni provides support for many printers with a pluggable framework (easy to add devices)"
HOMEPAGE="http://sourceforge.net/projects/omniprint"
-MY_P=${P/o/O}
-SRC_URI="mirror://sourceforge/omniprint/${MY_P}.tar.gz"
+SRC_URI="mirror://sourceforge/omniprint/${P/o/O}.tar.gz"
LICENSE="LGPL-2"
SLOT="0"
KEYWORDS="x86"
@@ -23,38 +22,28 @@ S=${WORKDIR}/Omni
IUSE="cups X ppds foomaticdb static"
src_compile() {
- use X \
- && myconf="${myconf} --enable-jobdialog" \
- || myconf="${myconf} --disable-jobdialog"
- use cups \
- && myconf="${myconf} --enable-cups" \
- || myconf="${myconf} --disable-cups"
- use static \
- && myconf="${myconf} --enable-static" \
- || myconf="${myconf} --disable-static"
+ local myconf=" \
+ $(use_enable X jobdialog) \
+ $(use_enable cups) \
+ $(use_enable static)"
./setupOmni ${myconf} || die
- if [ "`use ppds`" -a "`use cups`" ]; then
- cd CUPS
- sed -i -e "s/model\/foomatic/model\/omni/g" Makefile
-
- make generateBuildPPDs || die
- cd ..
+ if use ppds || use cups; then
+ sed -i -e "s/model\/foomatic/model\/omni/g" CUPS/Makefile \
+ || die 'sed failed'
+ make -C CUPS generateBuildPPDs || die
fi
- if [ `use foomaticdb` ]; then
- cd Foomatic
- make generateFoomaticData || die
- cd ..
+
+ if use foomaticdb; then
+ make -C Foomatic generateFoomaticData || die
fi
}
src_install () {
make DESTDIR=${D} install || die
- if [ `use foomaticdb` ]; then
- cd Foomatic
- make DESTDIR=${D} localInstall || die
- cd ..
+ if use foomaticdb; then
+ make -C foomaticdb DESTDIR=${D} localInstall || die
fi
}
diff --git a/net-print/pdq/Manifest b/net-print/pdq/Manifest
index ebf749ea1025..46bcd5ef89b2 100644
--- a/net-print/pdq/Manifest
+++ b/net-print/pdq/Manifest
@@ -1,4 +1,4 @@
-MD5 e59364cb588f4bbc2de30b4b109e338e pdq-2.2.1-r1.ebuild 1493
-MD5 0a848fa69ccbdbb439393c20cd5af0c9 ChangeLog 863
+MD5 cb843ebdc4f2e6cc2c4b61b7e2388c77 pdq-2.2.1-r1.ebuild 1520
+MD5 6ea1cf394160056351471828630a6d2d ChangeLog 1048
MD5 26b4b081d538c195dc39bcb2ec8e6f3a metadata.xml 161
MD5 574ad9ac0e6bc417f24d2ff3192e0ce3 files/digest-pdq-2.2.1-r1 58