summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-24 20:13:37 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-24 20:13:37 +0000
commitcbb2836bed2c8b3f7e9dd0f97d1fb4df3e1be3c8 (patch)
tree58118308d1358e93c26a80518b488c879b347619
parentminor fixes for rc5 (diff)
downloadhistorical-cbb2836bed2c8b3f7e9dd0f97d1fb4df3e1be3c8.tar.gz
historical-cbb2836bed2c8b3f7e9dd0f97d1fb4df3e1be3c8.tar.bz2
historical-cbb2836bed2c8b3f7e9dd0f97d1fb4df3e1be3c8.zip
minor fixes for rc5
-rw-r--r--net-analyzer/ethereal/ethereal-0.8.18.ebuild6
-rw-r--r--net-fs/samba-winbind/samba-winbind-20010329.ebuild6
-rw-r--r--net-ftp/ncftp/ncftp-3.0.2.ebuild8
-rw-r--r--net-im/everybuddy/everybuddy-0.2.1.ebuild4
-rw-r--r--net-mail/ssmtp/ssmtp-2.38.14-r1.ebuild6
-rw-r--r--net-print/LPRng/LPRng-3.6.26.ebuild4
-rw-r--r--net-www/apache-ssl/apache-ssl-1.3.20.2.8.4.ebuild3
7 files changed, 20 insertions, 17 deletions
diff --git a/net-analyzer/ethereal/ethereal-0.8.18.ebuild b/net-analyzer/ethereal/ethereal-0.8.18.ebuild
index 7b8f75eb5603..660e41a1561d 100644
--- a/net-analyzer/ethereal/ethereal-0.8.18.ebuild
+++ b/net-analyzer/ethereal/ethereal-0.8.18.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.8.18.ebuild,v 1.3 2001/06/17 17:55:26 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethereal/ethereal-0.8.18.ebuild,v 1.4 2001/06/24 20:13:37 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -33,14 +33,14 @@ src_compile() {
fi
LDFLAGS="-L/usr/lib -lz" try ./configure --host=${CHOST} --prefix=/usr --with-plugindir=/usr/lib/ethereal/plugins/${PV} \
- --sysconfdir=/etc/ethereal --enable-pcap --enable-zlib --enable-ipv6 $myconf
+ --mandir=/usr/share/man --sysconfdir=/etc/ethereal --enable-pcap --enable-zlib --enable-ipv6 $myconf
try make
}
src_install() {
dodir /usr/lib/ethereal/plugins/${PV}
- try make prefix=${D}/usr sysconfdir=${D}/etc/ethereal \
+ try make prefix=${D}/usr sysconfdir=${D}/etc/ethereal mandir=${D}/usr/share/man \
plugindir=${D}/usr/lib/ethereal/plugins/${PV} install
dodoc AUTHORS COPYING ChangeLog INSTALL.* NEWS README* TODO
diff --git a/net-fs/samba-winbind/samba-winbind-20010329.ebuild b/net-fs/samba-winbind/samba-winbind-20010329.ebuild
index d114bb151f7b..6cb3b803d84a 100644
--- a/net-fs/samba-winbind/samba-winbind-20010329.ebuild
+++ b/net-fs/samba-winbind/samba-winbind-20010329.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-fs/samba-winbind/samba-winbind-20010329.ebuild,v 1.3 2001/05/28 14:32:32 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/samba-winbind/samba-winbind-20010329.ebuild,v 1.4 2001/06/24 20:13:37 achim Exp $
A=samba-tng-cvs-${PV}.tbz2
S=${WORKDIR}/tng
@@ -23,7 +23,9 @@ src_compile() {
local myconf
if [ "`use pam`" ]
then
- myconf="--with-pam"
+ myconf="--without-pam"
+ echo "disabled cuz broken"
+# myconf="--with-pam"
else
myconf="--without-pam"
fi
diff --git a/net-ftp/ncftp/ncftp-3.0.2.ebuild b/net-ftp/ncftp/ncftp-3.0.2.ebuild
index bfd63fda28b0..dd9dc20d4dc8 100644
--- a/net-ftp/ncftp/ncftp-3.0.2.ebuild
+++ b/net-ftp/ncftp/ncftp-3.0.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Jerry Alexandratos <jerry@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-ftp/ncftp/ncftp-3.0.2.ebuild,v 1.3 2001/05/28 05:24:13 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/ncftp/ncftp-3.0.2.ebuild,v 1.4 2001/06/24 20:13:37 achim Exp $
A=${P}-src.tar.gz
S=${WORKDIR}/${P}
@@ -13,13 +13,13 @@ DEPEND="virtual/glibc >=sys-libs/ncurses-5.2"
src_compile() {
- try ./configure --prefix=/usr --host=${CHOST}
+ try ./configure --prefix=/usr/share/man --host=${CHOST}
try make
}
src_install () {
-
- try make prefix=${D}/usr install
+ dodir /usr/share
+ try make prefix=${D}/usr mandir=${D}/usr/share/man install
dodoc CHANGELOG FIREWALL-PROXY-README LICENSE.txt
READLINE-README README WHATSNEW-3.0
diff --git a/net-im/everybuddy/everybuddy-0.2.1.ebuild b/net-im/everybuddy/everybuddy-0.2.1.ebuild
index 8608fad9944a..c8cd9cf86008 100644
--- a/net-im/everybuddy/everybuddy-0.2.1.ebuild
+++ b/net-im/everybuddy/everybuddy-0.2.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Ben Lutgens <blutgens@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-im/everybuddy/everybuddy-0.2.1.ebuild,v 1.2 2001/05/25 15:42:29 blutgens Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/everybuddy/everybuddy-0.2.1.ebuild,v 1.3 2001/06/24 20:13:37 achim Exp $
A=everybuddy-0.2.1beta3.tar.gz
S=${WORKDIR}/everybuddy-0.2.1beta3
@@ -19,7 +19,7 @@ src_compile() {
myconf="--disable-arts"
fi
- try ./configure --prefix=/usr --host=${CHOST} ${myconf}
+ try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} ${myconf}
try make
}
diff --git a/net-mail/ssmtp/ssmtp-2.38.14-r1.ebuild b/net-mail/ssmtp/ssmtp-2.38.14-r1.ebuild
index b9c924e26284..cd9662560b88 100644
--- a/net-mail/ssmtp/ssmtp-2.38.14-r1.ebuild
+++ b/net-mail/ssmtp/ssmtp-2.38.14-r1.ebuild
@@ -7,10 +7,10 @@ S=${WORKDIR}/${P}
DESCRIPTION="Extremely simple MTA to get mail off the system to a Mailhub"
SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/system/mail/mta/${A}"
-DEPEND="virtual/glibc
- >=net-mail/mailbase-0.00"
+DEPEND="virtual/glibc"
-RDEPEND="!virtual/mta"
+
+RDEPEND="!virtual/mtai net-mail/mailbase"
PROVIDE="virtual/mta"
diff --git a/net-print/LPRng/LPRng-3.6.26.ebuild b/net-print/LPRng/LPRng-3.6.26.ebuild
index 8c664f2de12e..68fa7eacc973 100644
--- a/net-print/LPRng/LPRng-3.6.26.ebuild
+++ b/net-print/LPRng/LPRng-3.6.26.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-print/LPRng/LPRng-3.6.26.ebuild,v 1.5 2001/05/29 17:28:19 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-print/LPRng/LPRng-3.6.26.ebuild,v 1.6 2001/06/24 20:13:37 achim Exp $
A=${P}.tgz
S=${WORKDIR}/${P}
@@ -27,7 +27,7 @@ src_compile() {
myconf="--enable-nls"
fi
try ./configure --host=${CHOST} --prefix=/usr --sysconfdir=/etc/lprng \
- $myconf
+ --mandir=/usr/share/man --libexecdir=/usr/lib $myconf
try make
}
diff --git a/net-www/apache-ssl/apache-ssl-1.3.20.2.8.4.ebuild b/net-www/apache-ssl/apache-ssl-1.3.20.2.8.4.ebuild
index ce04c450c9ff..f95ca0e158c9 100644
--- a/net-www/apache-ssl/apache-ssl-1.3.20.2.8.4.ebuild
+++ b/net-www/apache-ssl/apache-ssl-1.3.20.2.8.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache-ssl/apache-ssl-1.3.20.2.8.4.ebuild,v 1.4 2001/06/17 12:51:07 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache-ssl/apache-ssl-1.3.20.2.8.4.ebuild,v 1.5 2001/06/24 20:13:37 achim Exp $
AV="1.3.20"
MSV="2.8.4"
@@ -51,6 +51,7 @@ src_install() {
sed -e "s:^PIDFILE.*:PIDFILE=/var/run/httpd.pid:" \
apachectl.orig > apachectl
rm apachectl.orig
+ cd ${S}
dodoc ABOUT_APACHE Announcement INSTALL* KEYS LICENSE* README* WARNING*
docinto mod_ssl
cd ../mod_ssl-${MSV}-${AV}