summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-01-12 22:09:12 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-01-12 22:09:12 +0000
commite4be792332925c08e143224e40539a63510b5c51 (patch)
tree741eab0580de62cca0599ae2a346188900a93340
parentMissed shaders directory in original install - 232188 (diff)
downloadhistorical-e4be792332925c08e143224e40539a63510b5c51.tar.gz
historical-e4be792332925c08e143224e40539a63510b5c51.tar.bz2
historical-e4be792332925c08e143224e40539a63510b5c51.zip
version bump
Package-Manager: portage-2.2_rc20/cvs/Linux 2.6.28 x86_64
-rw-r--r--media-libs/mlt++/ChangeLog10
-rw-r--r--media-libs/mlt++/files/mlt++-0.3.4-asneeded.patch58
-rw-r--r--media-libs/mlt++/mlt++-0.3.4.ebuild35
-rw-r--r--media-libs/mlt/ChangeLog9
-rw-r--r--media-libs/mlt/mlt-0.3.4.ebuild96
5 files changed, 204 insertions, 4 deletions
diff --git a/media-libs/mlt++/ChangeLog b/media-libs/mlt++/ChangeLog
index d7d4894f8e27..87456ed886b5 100644
--- a/media-libs/mlt++/ChangeLog
+++ b/media-libs/mlt++/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/mlt++
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt++/ChangeLog,v 1.14 2008/11/13 10:08:18 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt++/ChangeLog,v 1.15 2009/01/12 22:09:12 aballier Exp $
+
+*mlt++-0.3.4 (12 Jan 2009)
+
+ 12 Jan 2009; Alexis Ballier <aballier@gentoo.org>
+ +files/mlt++-0.3.4-asneeded.patch, +mlt++-0.3.4.ebuild:
+ version bump
*mlt++-0.3.2 (13 Nov 2008)
diff --git a/media-libs/mlt++/files/mlt++-0.3.4-asneeded.patch b/media-libs/mlt++/files/mlt++-0.3.4-asneeded.patch
new file mode 100644
index 000000000000..568ad6ea9000
--- /dev/null
+++ b/media-libs/mlt++/files/mlt++-0.3.4-asneeded.patch
@@ -0,0 +1,58 @@
+Index: mlt++-0.3.4/configure
+===================================================================
+--- mlt++-0.3.4.orig/configure
++++ mlt++-0.3.4/configure
+@@ -38,13 +38,13 @@ case $targetos in
+ echo LIBSUF=.dylib
+ echo "CXXFLAGS+=-D__DARWIN__ -Wall -fPIC `pkg-config --cflags mlt-framework`"
+ echo "LIBFLAGS=-dynamiclib -single_module"
+- echo "LDFLAGS+=`pkg-config --libs mlt-framework` `pkg-config mlt-miracle --libs` `pkg-config mlt-valerie --libs`"
++ echo "OURLDFLAGS+=`pkg-config --libs mlt-framework` `pkg-config mlt-miracle --libs` `pkg-config mlt-valerie --libs`"
+ ;;
+ Linux|FreeBSD)
+ echo LIBSUF=.so
+ echo "CXXFLAGS+=-pthread -Wall -fPIC `pkg-config --cflags mlt-framework`"
+ echo "LIBFLAGS=-shared"
+- echo "LDFLAGS+=`pkg-config --libs mlt-framework` `pkg-config mlt-miracle --libs`"
++ echo "OURLDFLAGS+=`pkg-config --libs mlt-framework` `pkg-config mlt-miracle --libs`"
+ ;;
+ esac >> config.mak
+
+Index: mlt++-0.3.4/src/Makefile
+===================================================================
+--- mlt++-0.3.4.orig/src/Makefile
++++ mlt++-0.3.4/src/Makefile
+@@ -43,7 +43,7 @@ HEADERS = config.h Mlt.h $(OBJS:.o=.h)
+ all: $(TARGET)
+
+ $(TARGET): $(OBJS)
+- $(CXX) $(LIBFLAGS) -o $@ $(OBJS) $(LDFLAGS)
++ $(CXX) $(LIBFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(OURLDFLAGS)
+ ln -sf $(TARGET) $(NAME)
+ ln -sf $(TARGET) $(SONAME)
+
+Index: mlt++-0.3.4/test/Makefile
+===================================================================
+--- mlt++-0.3.4.orig/test/Makefile
++++ mlt++-0.3.4/test/Makefile
+@@ -1,16 +1,19 @@
+ include ../config.mak
+
+ CXXFLAGS+=-Wall -g `pkg-config mlt-framework --cflags` -I ../src
+-LDFLAGS+=-L../src -lmlt++ -lmiracle -lvalerie `pkg-config mlt-framework --libs`
++OURLDFLAGS+=-lmlt++ -lmiracle -lvalerie `pkg-config mlt-framework --libs`
++LDFLAGS+=-L../src
+ CC=c++
+
+ all: play server
+
+ play: play.o
++ $(CC) $(LDFLAGS) -o $@ play.o $(OURLDFLAGS)
+
+ play.o: play.cpp
+
+ server: server.o
++ $(CC) $(LDFLAGS) -o $@ server.o $(OURLDFLAGS)
+
+ server.o: server.cpp
+
diff --git a/media-libs/mlt++/mlt++-0.3.4.ebuild b/media-libs/mlt++/mlt++-0.3.4.ebuild
new file mode 100644
index 000000000000..fced9a86bc77
--- /dev/null
+++ b/media-libs/mlt++/mlt++-0.3.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt++/mlt++-0.3.4.ebuild,v 1.1 2009/01/12 22:09:12 aballier Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Various bindings for mlt"
+HOMEPAGE="http://mlt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mlt/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=media-libs/mlt-0.3.4"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-0.3.4-asneeded.patch"
+}
+
+src_compile() {
+ tc-export CXX
+ econf
+ emake CC="$(tc-getCXX)" || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dodoc README CUSTOMISING HOWTO
+}
diff --git a/media-libs/mlt/ChangeLog b/media-libs/mlt/ChangeLog
index 3ccfb6c509c4..e722e91220d2 100644
--- a/media-libs/mlt/ChangeLog
+++ b/media-libs/mlt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/mlt
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/ChangeLog,v 1.33 2008/11/23 12:40:21 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/ChangeLog,v 1.34 2009/01/12 22:07:49 aballier Exp $
+
+*mlt-0.3.4 (12 Jan 2009)
+
+ 12 Jan 2009; Alexis Ballier <aballier@gentoo.org> +mlt-0.3.4.ebuild:
+ version bump
23 Nov 2008; Alexis Ballier <aballier@gentoo.org>
-files/mlt-0.3.0-avcodec.patch, -files/mlt-0.3.0-sox1410.patch:
diff --git a/media-libs/mlt/mlt-0.3.4.ebuild b/media-libs/mlt/mlt-0.3.4.ebuild
new file mode 100644
index 000000000000..b2eeb96da9f9
--- /dev/null
+++ b/media-libs/mlt/mlt-0.3.4.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/mlt/mlt-0.3.4.ebuild,v 1.1 2009/01/12 22:07:49 aballier Exp $
+
+EAPI=1
+
+inherit eutils toolchain-funcs qt3
+
+DESCRIPTION="MLT is an open source multimedia framework, designed and developed
+for television broadcasting"
+HOMEPAGE="http://mlt.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mlt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="dv xml jack gtk sdl vorbis sox quicktime mmx lame xine lame ogg theora xine ffmpeg libsamplerate qt3 sse"
+
+DEPEND="ffmpeg? ( >=media-video/ffmpeg-0.4.9_p20080326 )
+ dv? ( >=media-libs/libdv-0.104 )
+ xml? ( >=dev-libs/libxml2-2.5 )
+ ogg? ( >=media-libs/libogg-1.1.3 )
+ vorbis? ( >=media-libs/libvorbis-1.1.2 )
+ sdl? ( >=media-libs/libsdl-1.2.10
+ >=media-libs/sdl-image-1.2.4 )
+ libsamplerate? ( >=media-libs/libsamplerate-0.1.2 )
+ jack? ( media-sound/jack-audio-connection-kit
+ media-libs/ladspa-sdk
+ >=dev-libs/libxml2-2.5 )
+ gtk? ( >=x11-libs/gtk+-2
+ x11-libs/pango )
+ sox? ( media-sound/sox )
+ quicktime? ( media-libs/libquicktime )
+ xine? ( >=media-libs/xine-lib-1.1.2_pre20060328-r7 )
+ lame? ( >=media-sound/lame-3.97_beta2 )
+ qt3? ( x11-libs/qt:3 )
+ theora? ( >=media-libs/libtheora-1.0_alpha5 )"
+RDEPEND=${DEPEND}
+
+pkg_setup() {
+ local fail="USE sox needs also USE libsamplerate enabled."
+
+ if use sox && ! use libsamplerate; then
+ eerror "${fail}"
+ die "${fail}"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/mlt-0.2.3-nostrip.patch
+}
+
+src_compile() {
+ tc-export CC
+
+ local myconf=" --enable-gpl --enable-shared
+ --enable-pp --enable-shared-pp
+ --enable-motion-est
+ $(use_enable dv)
+ $(use_enable mmx)
+ $(use_enable sse)
+ $(use_enable gtk gtk2)
+ $(use_enable vorbis)
+ $(use_enable ogg)
+ $(use_enable sdl)
+ $(use_enable jack jackrack)
+ $(use_enable sox)
+ $(use_enable theora)
+ $(use_enable lame mp3lame)
+ $(use_enable ffmpeg avformat)
+ $(use_enable libsamplerate resample)
+ $(use_enable qt3 qimage)
+ $(use_enable xml westley)
+ $(use_enable xine)"
+
+ use ffmpeg && has_version ">=media-video/ffmpeg-0.4.9_p20070616-r20" &&
+ myconf="${myconf} --avformat-swscale"
+
+ (use quicktime && use dv) || myconf="${myconf} --disable-kino"
+
+ econf ${myconf} || die "econf failed"
+ sed -i -e s/^OPT/#OPT/ "${S}/config.mak"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc docs/*.txt ChangeLog README docs/TODO
+
+ dodir /usr/share/${PN}
+ insinto /usr/share/${PN}
+ doins -r demo
+}