summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-05-08 01:56:53 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-05-08 01:56:53 +0000
commited5cfe18aa9106fc0da8f3301514ef3b74503041 (patch)
treefe0f7689f3d5d7a954cd13531489961f5ab9d85e
parentMarked stable on amd64 and x86. (diff)
downloadhistorical-ed5cfe18aa9106fc0da8f3301514ef3b74503041.tar.gz
historical-ed5cfe18aa9106fc0da8f3301514ef3b74503041.tar.bz2
historical-ed5cfe18aa9106fc0da8f3301514ef3b74503041.zip
Initial commit.
Package-Manager: portage-2.0.51.21-r1
-rw-r--r--app-admin/eclectic/ChangeLog10
-rw-r--r--app-admin/eclectic/Manifest14
-rw-r--r--app-admin/eclectic/eclectic-0.9.1.ebuild37
-rw-r--r--app-admin/eclectic/files/digest-eclectic-0.9.11
-rw-r--r--app-admin/eclectic/metadata.xml9
5 files changed, 71 insertions, 0 deletions
diff --git a/app-admin/eclectic/ChangeLog b/app-admin/eclectic/ChangeLog
new file mode 100644
index 000000000000..bafd85a741c5
--- /dev/null
+++ b/app-admin/eclectic/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-admin/eclectic
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eclectic/ChangeLog,v 1.1 2005/05/08 01:56:53 ka0ttic Exp $
+
+*eclectic-0.9.1 (08 May 2005)
+
+ 08 May 2005; Aaron Walker <ka0ttic@gentoo.org> +metadata.xml,
+ +eclectic-0.9.1.ebuild:
+ Initial commit.
+
diff --git a/app-admin/eclectic/Manifest b/app-admin/eclectic/Manifest
new file mode 100644
index 000000000000..1368934efc9e
--- /dev/null
+++ b/app-admin/eclectic/Manifest
@@ -0,0 +1,14 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 19e2730098ca5395a35796629412ad23 eclectic-0.9.1.ebuild 996
+MD5 9a62f317c0ea253958d00d743c9ed2f3 ChangeLog 350
+MD5 75a24622ebfeeb52a3ab749d648e203b metadata.xml 227
+MD5 1af62ea0480a2d7a06b479a80219ab16 files/digest-eclectic-0.9.1 66
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.4.1 (GNU/Linux)
+
+iD8DBQFCfXIoEZCkKN40op4RAsOwAKDDm65cWJtUnWU5K+9iVSO880jqvgCcD1Bx
+lDb7NVa39UxjD0o8zGOA9TM=
+=GqjT
+-----END PGP SIGNATURE-----
diff --git a/app-admin/eclectic/eclectic-0.9.1.ebuild b/app-admin/eclectic/eclectic-0.9.1.ebuild
new file mode 100644
index 000000000000..b4fde6be777b
--- /dev/null
+++ b/app-admin/eclectic/eclectic-0.9.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eclectic/eclectic-0.9.1.ebuild,v 1.1 2005/05/08 01:56:53 ka0ttic Exp $
+
+inherit bash-completion
+
+DESCRIPTION="Modular -config replacement utility"
+HOMEPAGE="http://developer.berlios.de/projects/eclectic/"
+SRC_URI="http://download.berlios.de/eclectic/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+RDEPEND="app-shells/bash
+ doc? ( dev-python/docutils )"
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+ if use doc ; then
+ cd doc ; make html || die "failed to build html"
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # removed until fixed/profiles.desc updated
+ rm ${D}/usr/share/eclectic/modules/profile.eclectic
+ rm ${D}/usr/share/man/man5/profile.eclectic.5
+
+ dodoc README doc/*.txt
+ use doc && dohtml doc/*.html
+ dobashcompletion misc/eclectic.bashcomp
+}
diff --git a/app-admin/eclectic/files/digest-eclectic-0.9.1 b/app-admin/eclectic/files/digest-eclectic-0.9.1
new file mode 100644
index 000000000000..f2ddf0c24e4f
--- /dev/null
+++ b/app-admin/eclectic/files/digest-eclectic-0.9.1
@@ -0,0 +1 @@
+MD5 5f629a4bd17967d8180fe5f76bcd31af eclectic-0.9.1.tar.bz2 63330
diff --git a/app-admin/eclectic/metadata.xml b/app-admin/eclectic/metadata.xml
new file mode 100644
index 000000000000..b9e773728831
--- /dev/null
+++ b/app-admin/eclectic/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>ciaranm@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
+