summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-01-07 07:18:29 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-01-07 07:18:29 +0000
commitfc9d6a608d7eab7cd61a8be8e8c84afeba4f8f3e (patch)
tree895f1619d193d5a728fd97083cce5adad608b4e9
parentAdded pkgconfig DEPEND. (diff)
downloadhistorical-fc9d6a608d7eab7cd61a8be8e8c84afeba4f8f3e.tar.gz
historical-fc9d6a608d7eab7cd61a8be8e8c84afeba4f8f3e.tar.bz2
historical-fc9d6a608d7eab7cd61a8be8e8c84afeba4f8f3e.zip
multilib and cross-compilation fixes.
-rw-r--r--net-libs/courier-authlib/ChangeLog6
-rw-r--r--net-libs/courier-authlib/Manifest14
-rw-r--r--net-libs/courier-authlib/courier-authlib-0.52.ebuild10
3 files changed, 15 insertions, 15 deletions
diff --git a/net-libs/courier-authlib/ChangeLog b/net-libs/courier-authlib/ChangeLog
index 9b0c6d6bc4ff..032ac97c0c46 100644
--- a/net-libs/courier-authlib/ChangeLog
+++ b/net-libs/courier-authlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/courier-authlib
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/ChangeLog,v 1.20 2005/01/02 07:27:54 langthang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/ChangeLog,v 1.21 2005/01/07 07:18:29 eradicator Exp $
+
+ 06 Jan 2005; Jeremy Huddleston <eradicator@gentoo.org>
+ courier-authlib-0.52.ebuild:
+ multilib and cross-compilation fixes.
01 Jan 2005; Tuan Van <langthang@gentoo.org> courier-authlib-0.52.ebuild:
add "libtoolize --copy --force"
diff --git a/net-libs/courier-authlib/Manifest b/net-libs/courier-authlib/Manifest
index 74a870960ea7..576b3e1b779f 100644
--- a/net-libs/courier-authlib/Manifest
+++ b/net-libs/courier-authlib/Manifest
@@ -1,18 +1,18 @@
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
-MD5 76ad08c3f6a12d825df705f31ef554c6 courier-authlib-0.52.ebuild 5144
+MD5 9bb476d7c1b83f421761cbc4c675896d ChangeLog 3198
MD5 088c1350a14be1b1e72bf88c884abce1 courier-authlib-0.50.20041203.ebuild 5042
-MD5 bf6904c108455097f2f3de26ac0c046b ChangeLog 3068
MD5 1639b87658242c2406f7f7f8deda7388 metadata.xml 334
-MD5 a01734679d1906a8886eccdcf66a20f5 files/digest-courier-authlib-0.52 74
+MD5 57d450126c904e2546ec0639cd668c66 courier-authlib-0.52.ebuild 5052
+MD5 6930587c358320ecb1043761d7ff97f1 files/configure-db4.patch 2544
MD5 4c7dedb4c21da2d9e4dbc586459de426 files/courier-authlib-initd 1038
MD5 55e872f718ada612e49cc176cb627db8 files/digest-courier-authlib-0.50.20041203 83
-MD5 6930587c358320ecb1043761d7ff97f1 files/configure-db4.patch 2544
+MD5 a01734679d1906a8886eccdcf66a20f5 files/digest-courier-authlib-0.52 74
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)
-iD8DBQFB16KH5FrxP71izLARArerAJ4gorac2pQ2aDasUQ2w5jnGUwNJBQCgtluM
-G8Q9Ns3QI2cCaZRTLgCmiXE=
-=KBWg
+iD8DBQFB3jfTArHZZzCEUG0RAiJhAJ970jKj3b+RzC4y7F1X3opbsYaimgCfdVGw
+QYCTMPlr9MSZHlJbXLCJ0pY=
+=IWYl
-----END PGP SIGNATURE-----
diff --git a/net-libs/courier-authlib/courier-authlib-0.52.ebuild b/net-libs/courier-authlib/courier-authlib-0.52.ebuild
index 0707ea9ec7c9..df3e31f36e28 100644
--- a/net-libs/courier-authlib/courier-authlib-0.52.ebuild
+++ b/net-libs/courier-authlib/courier-authlib-0.52.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/courier-authlib-0.52.ebuild,v 1.2 2005/01/02 07:27:54 langthang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/courier-authlib/courier-authlib-0.52.ebuild,v 1.3 2005/01/07 07:18:29 eradicator Exp $
inherit eutils gnuconfig
@@ -79,9 +79,7 @@ src_compile() {
ewarn "${myconf}"
- ./configure \
- --prefix=/usr \
- --mandir=/usr/share/man \
+ econf \
--sysconfdir=/etc/courier \
--datadir=/usr/share/courier \
--libexecdir=/usr/lib/courier \
@@ -92,8 +90,7 @@ src_compile() {
--with-mailuser=mail \
--with-mailgroup=mail \
--cache-file=${S}/configuring.cache \
- --build=${CHOST} \
- --host=${CHOST} ${myconf} || die "bad ./configure"
+ ${myconf} || die "bad ./configure"
emake || die "Compile problem"
}
@@ -142,4 +139,3 @@ pkg_postinst() {
einfo " rm `echo \"${list}\" | xargs echo`"
fi
}
-