summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-03-09 20:52:52 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-03-09 20:52:52 +0000
commitd48bd65470a486cc4aeefbebcd70f1a9061ddb81 (patch)
tree48b0e10cf7428efc6120dbccdbd7b9b22bad615e /app-admin/diradm/diradm-2.9.ebuild
parentRemove failing tests. (diff)
downloadhistorical-d48bd65470a486cc4aeefbebcd70f1a9061ddb81.tar.gz
historical-d48bd65470a486cc4aeefbebcd70f1a9061ddb81.tar.bz2
historical-d48bd65470a486cc4aeefbebcd70f1a9061ddb81.zip
Remove older versions.
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'app-admin/diradm/diradm-2.9.ebuild')
-rw-r--r--app-admin/diradm/diradm-2.9.ebuild68
1 files changed, 0 insertions, 68 deletions
diff --git a/app-admin/diradm/diradm-2.9.ebuild b/app-admin/diradm/diradm-2.9.ebuild
deleted file mode 100644
index bd3df9e76543..000000000000
--- a/app-admin/diradm/diradm-2.9.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/diradm/diradm-2.9.ebuild,v 1.4 2007/04/26 02:58:06 robbat2 Exp $
-
-inherit eutils
-
-DESCRIPTION="diradm is a nearly complete nss/shadow suite for managing POSIX users/groups/data in LDAP."
-#HOMEPAGE="http://research.iat.sfu.ca/custom-software/diradm/"
-#SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
-HOMEPAGE="http://orbis-terrarum.net/~robbat2/"
-SRC_URI="http://orbis-terrarum.net/~robbat2/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~ppc64 ~ppc ~x86 ~amd64"
-IUSE="samba irixpasswd automount test"
-DEPEND="net-nds/openldap
- sys-apps/gawk
- sys-apps/coreutils
- sys-apps/grep
- dev-lang/perl
- app-shells/bash
- sys-apps/sed
- virtual/perl-MIME-Base64
- samba? (
- dev-perl/Crypt-SmbHash
- >=net-fs/samba-3.0.6
- )
- test? ( dev-perl/Crypt-SmbHash >=net-fs/samba-3.0.6 dev-util/dejagnu )"
-
-pkg_setup() {
- if use test; then
- if built_with_use net-nds/openldap minimal ; then
- die "You MUST have a non-minimal build of OpenLDAP to use the testcases!"
- fi
- elog "Warning, for test usage, diradm is built with all optional features!"
- fi
-}
-
-src_compile() {
- local myconf
- if use test; then
- myconf="--enable-samba --enable-automount --enable-irixpasswd"
- else
- myconf="`use_enable samba` `use_enable automount` `use_enable irixpasswd`"
- fi
- econf ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
- dodoc CHANGES* README AUTHORS ChangeLog NEWS README.prefork THANKS TODO KNOWN-BUGS
- if use irixpasswd; then
- insinto /etc/openldap/schema
- doins irixpassword.schema
- fi
-}
-
-pkg_postinst() {
- elog "The new diradm pulls many settings from your LDAP configuration."
- elog "But don't forget to customize /etc/diradm.conf for other settings."
- elog "Please see the README to instructions if you problems."
-}
-
-src_test() {
- emake -j1 check
-}