summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-24 21:09:16 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-24 21:09:16 +0000
commit96c32ffe2236372967d7b4b3faa77efa841941fd (patch)
tree45479c7b6d52142a45b9cc3e2d3c8d2b7eda4a15 /app-admin/eselect-python/eselect-python-20090824.ebuild
parentversion bump (diff)
downloadhistorical-96c32ffe2236372967d7b4b3faa77efa841941fd.tar.gz
historical-96c32ffe2236372967d7b4b3faa77efa841941fd.tar.bz2
historical-96c32ffe2236372967d7b4b3faa77efa841941fd.zip
Version bump.
Package-Manager: portage-14153-svn/cvs/Linux x86_64
Diffstat (limited to 'app-admin/eselect-python/eselect-python-20090824.ebuild')
-rw-r--r--app-admin/eselect-python/eselect-python-20090824.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/eselect-python/eselect-python-20090824.ebuild b/app-admin/eselect-python/eselect-python-20090824.ebuild
new file mode 100644
index 000000000000..89136058121c
--- /dev/null
+++ b/app-admin/eselect-python/eselect-python-20090824.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/eselect-python-20090824.ebuild,v 1.1 2009/08/24 21:09:16 arfrever Exp $
+
+EAPI="2"
+
+inherit flag-o-matic
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="http://www.gentoo.org"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=app-admin/eselect-1.0.2"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ append-flags -fno-PIC -fno-PIE
+}
+
+src_prepare() {
+ ./autogen.sh || die "autogen.sh failed"
+}
+
+src_install() {
+ keepdir /etc/env.d/python
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_preinst() {
+ if has_version "<${CATEGORY}/${PN}-20090804" || ! has_version "${CATEGORY}/${PN}"; then
+ run_eselect_python_update="1"
+ fi
+}
+
+pkg_postinst() {
+ if [[ "${run_eselect_python_update}" == "1" ]]; then
+ ebegin "Running \`eselect python update\`"
+ eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 > /dev/null
+ eend "$?"
+ fi
+}