summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-04-08 05:23:54 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-04-08 05:23:54 +0000
commit1a589a1a0e8e8d45df8ad52388ce292d8bc9d6f6 (patch)
treedc0ca4838b30cb75d29168ed06a1973687196b39 /app-admin/eselect/eselect-1.0.8.ebuild
parentfix postinst message to include instructions for enabling globally, bug 265168 (diff)
downloadhistorical-1a589a1a0e8e8d45df8ad52388ce292d8bc9d6f6.tar.gz
historical-1a589a1a0e8e8d45df8ad52388ce292d8bc9d6f6.tar.bz2
historical-1a589a1a0e8e8d45df8ad52388ce292d8bc9d6f6.zip
Version bump to fix bug 248470, patch by Thomas Bellman. Allows parent profiles to be selectable. Also, remove old versions
Package-Manager: portage-2.1.6.11/cvs/Linux x86_64
Diffstat (limited to 'app-admin/eselect/eselect-1.0.8.ebuild')
-rw-r--r--app-admin/eselect/eselect-1.0.8.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/app-admin/eselect/eselect-1.0.8.ebuild b/app-admin/eselect/eselect-1.0.8.ebuild
deleted file mode 100644
index 86ece98d3be2..000000000000
--- a/app-admin/eselect/eselect-1.0.8.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect/eselect-1.0.8.ebuild,v 1.3 2007/01/24 14:07:12 genone Exp $
-
-inherit eutils autotools
-
-DESCRIPTION="Modular -config replacement utility"
-HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="doc bash-completion"
-
-DEPEND="sys-apps/sed
- doc? ( dev-python/docutils )
- || (
- sys-apps/coreutils
- sys-freebsd/freebsd-bin
- app-admin/realpath
- )"
-RDEPEND="sys-apps/sed
- sys-apps/file"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}-fix-parallel-install.patch"
- eautoreconf
-}
-
-src_compile() {
- econf || die "econf failed"
- emake || die "emake failed"
-
- if use doc ; then
- make html || die "failed to build html"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO doc/*.txt
- use doc && dohtml *.html doc/*
-
- # we don't use bash-completion.eclass since eselect
- # is listed in RDEPEND.
- if use bash-completion ; then
- insinto /usr/share/bash-completion
- newins misc/${PN}.bashcomp ${PN} || die
- fi
-}
-
-pkg_postinst() {
- if use bash-completion ; then
- elog
- elog "To enable command-line completion for eselect, run:"
- elog
- elog " eselect bashcomp enable eselect"
- fi
-
- elog
- elog "Modules cblas.eselect, blas.eselect and lapack.eselect have"
- elog "been split-out to separate packages called:"
- elog
- elog " app-admin/eselect-cblas"
- elog " app-admin/eselect-blas"
- elog " app-admin/eselect-lapack"
- elog
-}