summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-04-04 13:46:29 +0000
committerJustin Lecher <jlec@gentoo.org>2013-04-04 13:46:29 +0000
commit78f80555766ac6bd8d4fe7320d5f8a945105a54a (patch)
tree11117dfd5a2f329fcccc30e6a3a53dc6f80b1783 /app-admin/pwgen/pwgen-2.06-r2.ebuild
parentFixed build failure (unknown type name 'intmax_t'). (diff)
downloadhistorical-78f80555766ac6bd8d4fe7320d5f8a945105a54a.tar.gz
historical-78f80555766ac6bd8d4fe7320d5f8a945105a54a.tar.bz2
historical-78f80555766ac6bd8d4fe7320d5f8a945105a54a.zip
app-admin/pwgen: Add to autotools-utils.eclass; eautoreconf for sane prefix header detection; drop old
Package-Manager: portage-2.2.0_alpha171/cvs/Linux x86_64 Manifest-Sign-Key: 0x8009D6F070EB7916
Diffstat (limited to 'app-admin/pwgen/pwgen-2.06-r2.ebuild')
-rw-r--r--app-admin/pwgen/pwgen-2.06-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-admin/pwgen/pwgen-2.06-r2.ebuild b/app-admin/pwgen/pwgen-2.06-r2.ebuild
new file mode 100644
index 000000000000..4ccd0478cb46
--- /dev/null
+++ b/app-admin/pwgen/pwgen-2.06-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/pwgen/pwgen-2.06-r2.ebuild,v 1.1 2013/04/04 13:46:28 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils toolchain-funcs
+
+DESCRIPTION="Password Generator"
+HOMEPAGE="http://sourceforge.net/projects/pwgen/"
+SRC_URI="mirror://sourceforge/pwgen/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="livecd"
+
+PATCHES=( "${FILESDIR}"/${PV}-special-char.patch )
+
+src_prepare() {
+ sed -i -e 's:$(prefix)/man/man1:$(mandir)/man1:g' Makefile.in || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=( --sysconfdir="${EPREFIX}"/etc/pwgen )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ use livecd && newinitd "${FILESDIR}"/pwgen.rc pwgen
+}