summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris PeBenito <pebenito@gentoo.org>2003-12-23 02:37:04 +0000
committerChris PeBenito <pebenito@gentoo.org>2003-12-23 02:37:04 +0000
commitaad360a3278880bd6396964c048d9cdd3dc450fd (patch)
tree347624155c6c090a3dde2550dc66a436409d05e4 /app-admin/setools
parentfix to make non-X really work (diff)
downloadhistorical-aad360a3278880bd6396964c048d9cdd3dc450fd.tar.gz
historical-aad360a3278880bd6396964c048d9cdd3dc450fd.tar.bz2
historical-aad360a3278880bd6396964c048d9cdd3dc450fd.zip
more sane tcl version handling
Diffstat (limited to 'app-admin/setools')
-rw-r--r--app-admin/setools/Manifest2
-rw-r--r--app-admin/setools/setools-1.1.ebuild25
2 files changed, 12 insertions, 15 deletions
diff --git a/app-admin/setools/Manifest b/app-admin/setools/Manifest
index b65e905db00d..824d11542f53 100644
--- a/app-admin/setools/Manifest
+++ b/app-admin/setools/Manifest
@@ -1,7 +1,7 @@
MD5 8fb317db54d945003dde0f10ae0f84a5 setools-1.0.1.ebuild 2164
MD5 418c2991b69fcf9d551aba29ae6f2b2e metadata.xml 505
MD5 ecd32fdee496ebce4c002e60b4d75967 ChangeLog 1242
-MD5 d0331678fec0f8d01ee896611868c627 setools-1.1.ebuild 3203
+MD5 e159ffc7e43e62d8fd9e52ca3c5f5388 setools-1.1.ebuild 3050
MD5 5564aa4a7b6c1f09a6b07813defbedd5 files/digest-setools-1.0.1 62
MD5 a8fb0b7e830355d9de617df14ceaf43b files/setools-1.1-fix_noX.diff 1328
MD5 471bf4cba5a334dcb65b4451a1b0ce07 files/digest-setools-1.1 60
diff --git a/app-admin/setools/setools-1.1.ebuild b/app-admin/setools/setools-1.1.ebuild
index 9fc6d6793ae2..a50b8c557fb2 100644
--- a/app-admin/setools/setools-1.1.ebuild
+++ b/app-admin/setools/setools-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/setools/setools-1.1.ebuild,v 1.2 2003/12/23 02:07:14 pebenito Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/setools/setools-1.1.ebuild,v 1.3 2003/12/23 02:36:48 pebenito Exp $
DESCRIPTION="SELinux policy tools"
HOMEPAGE="http://www.tresys.com/selinux_policy_tools.html"
@@ -22,11 +22,6 @@ RDEPEND="X? (
gtk? ( >=gnome-base/libglade-2.0 )
)"
-# adjust for tcl/tk versions
-has_version '>=dev-lang/tk-8.4' \
- && TCL_LIBS="-ltk8.4 -ltcl8.4 -lfl -lm -dl" \
- || TCL_LIBS="-ltk8.3 -ltcl8.3 -lfl -lm -dl"
-
src_unpack() {
unpack ${A}
cd ${S}
@@ -34,6 +29,10 @@ src_unpack() {
# fix the Makefile to listen to portage CFLAGS
sed -i -e "s:-O2:-O2 ${CFLAGS}:" ${S}/Makefile
+ # fix for tcl/tk version
+ has_version '=dev-lang/tk-8.4*' && \
+ sed -i -e 's:8.3:8.4:' ${S}/Makefile
+
# fix up the scripts we're going to install
sed -i -e 's:local/selinux/::g' ${S}/seuser/seuseradd
sed -i -e 's:local/selinux/::g' ${S}/seuser/seuserdel
@@ -45,7 +44,7 @@ src_unpack() {
# fix up the file contexts
sed -i -e 's:local/selinux/::' -e 's:local/::' ${S}/policy/seuser.fc
- # makefiles are broken, fix to not build tcl/tk stuff for non X
+ # makefiles are broken, fix to not build tcl stuff for non X
use X || epatch ${FILESDIR}/setools-1.1-fix_noX.diff
}
@@ -53,16 +52,14 @@ src_compile() {
cd ${S}
# build command line tools
- make all-nogui || die "command line tools compile failed"
+ emake all-nogui || die "command line tools compile failed"
if use X; then
- # adjust for tcl/tk versions
-
- make TCL_LIBS="${TCL_LIBS}" apol sepcut seuserx \
+ emake apol sepcut seuserx \
|| die "apol, sepcut, or seuserx compile failed"
if use gtk; then
- make seaudit || die "seaudit compile failed."
+ emake seaudit || die "seaudit compile failed."
fi
fi
@@ -84,7 +81,7 @@ src_install() {
if use X; then
# graphical tools
- make TCL_LIBS="${TCL_LIBS}" DESTDIR=${D} install-apol install-sepcut \
+ make DESTDIR=${D} install-apol install-sepcut \
|| die "apol and sepcut install failed."
if use gtk; then
@@ -95,7 +92,7 @@ src_install() {
if use selinux; then
if use X; then
- make TCL_LIBS="${TCL_LIBS}" DESTDIR=${D} install-seuserx \
+ make DESTDIR=${D} install-seuserx \
|| die "seuserx install failed."
else
make DESTDIR=${D} install-seuser \