summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-12-02 17:06:04 +0000
committerJorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>2008-12-02 17:06:04 +0000
commitce2d86b78c15ae68bdf8fb66b8be9e2fb8b17e98 (patch)
tree0937b4dbb08506314b3f1161a2fd6cfd31f27499 /app-admin/sysrqd/sysrqd-9.ebuild
parentMarking crda-0.9.5 ~ppc64 for bug 249606 (diff)
downloadhistorical-ce2d86b78c15ae68bdf8fb66b8be9e2fb8b17e98.tar.gz
historical-ce2d86b78c15ae68bdf8fb66b8be9e2fb8b17e98.tar.bz2
historical-ce2d86b78c15ae68bdf8fb66b8be9e2fb8b17e98.zip
Removed the executable bit from files/sysrqd.init as it's installed through newinitd, a wrapper for doinitd, that calls doexe which uses the EXEOPTIONS variable that
defaults to -m0755. Quoted some vars. Package-Manager: portage-2.2_rc16/cvs/Linux 2.6.27-gentoo-r2 x86_64
Diffstat (limited to 'app-admin/sysrqd/sysrqd-9.ebuild')
-rw-r--r--app-admin/sysrqd/sysrqd-9.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/app-admin/sysrqd/sysrqd-9.ebuild b/app-admin/sysrqd/sysrqd-9.ebuild
index 87159873900d..d44b9c212cda 100644
--- a/app-admin/sysrqd/sysrqd-9.ebuild
+++ b/app-admin/sysrqd/sysrqd-9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sysrqd/sysrqd-9.ebuild,v 1.2 2007/04/30 20:03:39 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sysrqd/sysrqd-9.ebuild,v 1.3 2008/12/02 17:06:04 jmbsvicetto Exp $
inherit eutils toolchain-funcs
@@ -15,8 +15,8 @@ DEPEND=""
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-config.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-config.patch"
}
src_compile() {
@@ -26,7 +26,7 @@ src_compile() {
src_install() {
dosbin sysrqd
- newinitd ${FILESDIR}/sysrqd.init sysrqd
+ newinitd "${FILESDIR}/sysrqd.init sysrqd"
local bindip='127.0.0.1' secret
declare -i secret