summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-10-30 00:48:08 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-10-30 00:48:08 +0000
commit474990860a66c0dc939cf431e21b610712ace8dd (patch)
tree63fa7b30aa3e1b91bb6bd2498005c2d157741aa2 /app-admin/testdisk/testdisk-6.5.ebuild
parentAdd mini colourblind balls #153287 by Rickard Närström. (diff)
downloadhistorical-474990860a66c0dc939cf431e21b610712ace8dd.tar.gz
historical-474990860a66c0dc939cf431e21b610712ace8dd.tar.bz2
historical-474990860a66c0dc939cf431e21b610712ace8dd.zip
Bug #152380, version bump, thanks to upstream for filing it to remind us. 6.5 is a candidate for stable in 30 days.
Package-Manager: portage-2.1.2_rc1
Diffstat (limited to 'app-admin/testdisk/testdisk-6.5.ebuild')
-rw-r--r--app-admin/testdisk/testdisk-6.5.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-admin/testdisk/testdisk-6.5.ebuild b/app-admin/testdisk/testdisk-6.5.ebuild
new file mode 100644
index 000000000000..fcd9215dc9d2
--- /dev/null
+++ b/app-admin/testdisk/testdisk-6.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/testdisk/testdisk-6.5.ebuild,v 1.1 2006/10/30 00:48:08 robbat2 Exp $
+
+
+DESCRIPTION="Multi-platform tool to check and undelete partition, supports reiserfs, ntfs, fat32, ext2/3 and many others. Also includes PhotoRec to recover pictures from digital camera memory."
+HOMEPAGE="http://www.cgsecurity.org/wiki/TestDisk"
+SRC_URI="http://www.cgsecurity.org/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static reiserfs ntfs jpeg"
+# WARNING: reiserfs support does NOT work with reiserfsprogs
+# you MUST use progsreiserfs-0.3.1_rc8 (the last version ever released).
+DEPEND=">=sys-libs/ncurses-5.2
+ jpeg? ( media-libs/jpeg )
+ ntfs? ( >=sys-fs/ntfsprogs-1.9.4 )
+ reiserfs? ( >=sys-fs/progsreiserfs-0.3.1_rc8 )
+ >=sys-fs/e2fsprogs-1.35"
+RDEPEND="!static? ( ${DEPEND} )"
+
+src_compile() {
+ local myconf
+ # --with-foo are broken, any use of --with/--without disable the
+ # functionality.
+ # The following variation must be used.
+ use reiserfs || myconf="${myconf} --without-reiserfs"
+ use ntfs || myconf="${myconf} --without-ntfs"
+ use jpeg || myconf="${myconf} --without-jpeg"
+
+ econf ${myconf} || die
+
+ # perform safety checks for NTFS and REISERFS
+ if useq ntfs && egrep -q 'undef HAVE_LIBNTFS\>' ${S}/config.h ; then
+ die "Failed to find NTFS library."
+ fi
+ if useq reiserfs && egrep -q 'undef HAVE_LIBREISERFS\>' ${S}/config.h ; then
+ die "Failed to find reiserfs library."
+ fi
+ if useq jpeg && egrep -q 'undef HAVE_LIBJPEG\>' ${S}/config.h ; then
+ die "Failed to find jpeg library."
+ fi
+
+ # this is static method is the same used by upstream for their 'static' make
+ # target, but better, as it doesn't break.
+ use static && append-ldflags -static
+
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ [ "$PF" != "$P" ] && mv ${D}/usr/share/doc/${P} ${D}/usr/share/doc/${PF}
+}
+