summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArcady Genkin <agenkin@gentoo.org>2002-03-03 16:35:40 +0000
committerArcady Genkin <agenkin@gentoo.org>2002-03-03 16:35:40 +0000
commit99532f123a7f52003b34c505ac04a5a18955ea73 (patch)
tree2361168e498abeafdd2c5aaf48634a8e58086daf /app-admin/watchdog
parentfoo (diff)
downloadhistorical-99532f123a7f52003b34c505ac04a5a18955ea73.tar.gz
historical-99532f123a7f52003b34c505ac04a5a18955ea73.tar.bz2
historical-99532f123a7f52003b34c505ac04a5a18955ea73.zip
The ebuild submitted by Leknor@Leknor.com (William A. McArthur, Jr.),
slightly changed. Closes bug 691.
Diffstat (limited to 'app-admin/watchdog')
-rw-r--r--app-admin/watchdog/ChangeLog10
-rw-r--r--app-admin/watchdog/files/5.2/watchdog22
-rw-r--r--app-admin/watchdog/files/digest-watchdog-5.21
-rw-r--r--app-admin/watchdog/watchdog-5.2.ebuild43
4 files changed, 76 insertions, 0 deletions
diff --git a/app-admin/watchdog/ChangeLog b/app-admin/watchdog/ChangeLog
new file mode 100644
index 000000000000..15863effdee0
--- /dev/null
+++ b/app-admin/watchdog/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-admin/watchdog
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/ChangeLog,v 1.1 2002/03/03 16:35:40 agenkin Exp $
+
+*watchdog-5.2 (Mar 3, 2002)
+
+ 3 Mar 2002; Arcady Genkin <agenkin@thpoon.com> watchdog-5.2.ebuild :
+
+ This is the first version of this package, submitted by
+ Leknor@Leknor.com (William A. McArthur, Jr.). \ No newline at end of file
diff --git a/app-admin/watchdog/files/5.2/watchdog b/app-admin/watchdog/files/5.2/watchdog
new file mode 100644
index 000000000000..669ceb9c5a49
--- /dev/null
+++ b/app-admin/watchdog/files/5.2/watchdog
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/files/5.2/watchdog,v 1.1 2002/03/03 16:35:40 agenkin Exp $
+
+depend() {
+ need localmount
+ use logger
+}
+
+start() {
+ ebegin "Starting watchdog"
+ [ ! -e /dev/watchdog ] && eend 1 "/dev/watchdog not found"
+ start-stop-daemon --start --quiet --exec /usr/sbin/watchdog
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping watchdog"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/watchdog
+ eend $?
+}
diff --git a/app-admin/watchdog/files/digest-watchdog-5.2 b/app-admin/watchdog/files/digest-watchdog-5.2
new file mode 100644
index 000000000000..ff7a265cda3f
--- /dev/null
+++ b/app-admin/watchdog/files/digest-watchdog-5.2
@@ -0,0 +1 @@
+MD5 aed04b6789fc592a401c05b8f3828a16 watchdog-5.2.tar.gz 126296
diff --git a/app-admin/watchdog/watchdog-5.2.ebuild b/app-admin/watchdog/watchdog-5.2.ebuild
new file mode 100644
index 000000000000..76cd8b869fda
--- /dev/null
+++ b/app-admin/watchdog/watchdog-5.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: William A. McArthur <Leknor@Leknor.com>
+# $Header: /var/cvsroot/gentoo-x86/app-admin/watchdog/watchdog-5.2.ebuild,v 1.1 2002/03/03 16:35:40 agenkin Exp $
+
+DESCRIPTION="A software watchdog."
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/"
+SRC_URI="http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/${P}.tar.gz"
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ # Two configure switches have been added to use /etc/watchdog
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/watchdog \
+ --with-configfile=/etc/watchdog/watchdog.conf \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ dodir /etc/watchdog
+ make DESTDIR="${D}" install || die
+
+ exeinto /etc/init.d
+ doexe "${FILESDIR}/${PVR}/watchdog"
+}
+
+pkg_postinst () {
+ einfo
+ einfo "To enable the start-up script run \"rc-update add watchdog boot\"."
+ einfo
+ if [ ! -e /dev/watchdog ]
+ then
+ ewarn
+ ewarn "No /dev/watchdog found! Make sure your kernel has watchdog support"
+ ewarn "compiled in or the kernel module is loaded. The watchdog service"
+ ewarn "will not start at boot until your kernel is configured properly."
+ ewarn
+ fi
+}