summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-09-14 21:57:19 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-09-14 21:57:19 +0000
commit3b29fb982c50f7ae25f9ab2b8cb99ecf050f0cfd (patch)
tree5cb04067b75efed448e03dabdc3246ba8100e1da /app-admin/webmin
parentversion bump (diff)
downloadhistorical-3b29fb982c50f7ae25f9ab2b8cb99ecf050f0cfd.tar.gz
historical-3b29fb982c50f7ae25f9ab2b8cb99ecf050f0cfd.tar.bz2
historical-3b29fb982c50f7ae25f9ab2b8cb99ecf050f0cfd.zip
version bump
Diffstat (limited to 'app-admin/webmin')
-rw-r--r--app-admin/webmin/Manifest4
-rw-r--r--app-admin/webmin/files/digest-webmin-1.1101
-rw-r--r--app-admin/webmin/webmin-1.110.ebuild75
3 files changed, 78 insertions, 2 deletions
diff --git a/app-admin/webmin/Manifest b/app-admin/webmin/Manifest
index f32cac3c3381..08223cd02102 100644
--- a/app-admin/webmin/Manifest
+++ b/app-admin/webmin/Manifest
@@ -1,7 +1,7 @@
MD5 7fdd3ae59bfbac3959bdc75e2b40e3dc webmin-1.100-r1.ebuild 1933
MD5 85e44244d64f3c9d6c9633fcc8d97d76 webmin-1.080.ebuild 1763
-MD5 7fdd3ae59bfbac3959bdc75e2b40e3dc webmin-1.110.ebuild 1933
-MD5 e8b96a6fc6a207499e81d140cb81897f ChangeLog 4113
+MD5 cb40517f041546a2deb41e238b72150c webmin-1.110.ebuild 1931
+MD5 95eb01bfb8efc0e71af2f5ab111686d8 ChangeLog 4305
MD5 31d430597ce4bb6b1d249fbc827688fc files/webmin-gentoo-init 306
MD5 bc8eb1c9de103599fc00b140b0ed1f9f files/uninstall.sh 260
MD5 c2e70e10958f50cd84c377b5963a8ced files/digest-webmin-1.080 65
diff --git a/app-admin/webmin/files/digest-webmin-1.110 b/app-admin/webmin/files/digest-webmin-1.110
new file mode 100644
index 000000000000..fd9dea713ee2
--- /dev/null
+++ b/app-admin/webmin/files/digest-webmin-1.110
@@ -0,0 +1 @@
+MD5 ca7099ba36fa61c6562ed5a93073310e webmin-1.110.tar.gz 6655602
diff --git a/app-admin/webmin/webmin-1.110.ebuild b/app-admin/webmin/webmin-1.110.ebuild
new file mode 100644
index 000000000000..6ce75794e82c
--- /dev/null
+++ b/app-admin/webmin/webmin-1.110.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webmin/webmin-1.110.ebuild,v 1.1 2003/09/14 21:57:17 seemant Exp $
+
+IUSE="ssl"
+
+DESCRIPTION="Webmin, a web-based system administration interface"
+SRC_URI="mirror://sourceforge/webadmin/${P}.tar.gz"
+HOMEPAGE="http://www.webmin.com/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND="dev-lang/perl
+ ssl? ( dev-perl/Net-SSLeay )"
+
+RDEPEND=""
+
+src_install() {
+ rm -f mount/freebsd-mounts*
+ rm -f mount/openbsd-mounts*
+ rm -f mount/macos-mounts*
+ (find . -name '*.cgi' ; find . -name '*.pl') | perl perlpath.pl /usr/bin/perl -
+ dodir /usr/libexec/webmin
+ dodir /etc/init.d
+ dodir /var
+ dodir /etc/pam.d
+ cp -rp * ${D}/usr/libexec/webmin
+ mv ${D}/usr/libexec/webmin/openslp/config \
+ ${D}/usr/libexec/webmin/openslp/config-gentoo-linux
+
+ exeinto /etc/init.d
+ #newexe webmin-gentoo-init webmin
+ #Bug submitted to webmin-maintainer.
+ #Check in next Version if corrected
+ newexe ${FILESDIR}/webmin-gentoo-init webmin
+
+ insinto /etc/pam.d/
+ newins webmin-pam webmin
+ echo gentoo > ${D}/usr/libexec/webmin/install-type
+
+ exeinto /etc/webmin
+ doexe ${FILESDIR}/uninstall.sh
+ use ssl sed -i 's:ssl=$ssl:ssl=1:' setup.sh
+}
+
+pkg_postinst() {
+ /etc/init.d/webmin stop >/dev/null 2>&1
+ stopstatus=$?
+ cd /usr/libexec/webmin
+ config_dir=/etc/webmin
+ var_dir=/var/webmin
+ perl=/usr/bin/perl
+ autoos=1
+ port=10000
+ login=root
+ crypt=`grep "^root:" /etc/shadow | cut -f 2 -d :`
+ host=`hostname`
+ ssl=0
+ atboot=0
+ nostart=1
+ nochown=1
+ autothird=1
+ nouninstall=1
+ noperlpath=1
+ export config_dir var_dir perl autoos port login crypt host ssl nochown autothird nouninstall nostart noperlpath
+ perl /usr/libexec/webmin/maketemp.pl
+ ./setup.sh >/tmp/.webmin/webmin-setup.out 2>&1
+
+ if [ "$stopstatus" = "0" ]; then
+ # Start if it was running before
+ /etc/init.d/webmin start
+ fi
+}