summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2005-12-05 00:02:15 +0000
committerStuart Herbert <stuart@gentoo.org>2005-12-05 00:02:15 +0000
commit40977f567c52adce5993026efbd8de461889cca4 (patch)
tree835d7a96947c7d4796aeedfb6c1dce26b521aa5c /app-admin
parentversion bump from upstream (diff)
downloadhistorical-40977f567c52adce5993026efbd8de461889cca4.tar.gz
historical-40977f567c52adce5993026efbd8de461889cca4.tar.bz2
historical-40977f567c52adce5993026efbd8de461889cca4.zip
Version bump; contains bug fixes
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/webapp-config/ChangeLog8
-rw-r--r--app-admin/webapp-config/Manifest4
-rw-r--r--app-admin/webapp-config/files/digest-webapp-config-1.50.21
-rw-r--r--app-admin/webapp-config/webapp-config-1.50.2.ebuild43
4 files changed, 54 insertions, 2 deletions
diff --git a/app-admin/webapp-config/ChangeLog b/app-admin/webapp-config/ChangeLog
index a0dd61f05bd8..902889ec9047 100644
--- a/app-admin/webapp-config/ChangeLog
+++ b/app-admin/webapp-config/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/webapp-config
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.3 2005/11/24 21:25:49 stuart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/ChangeLog,v 1.4 2005/12/05 00:02:15 stuart Exp $
+
+*webapp-config-1.50.2 (05 Dec 2005)
+
+ 05 Dec 2005; Stuart Herbert <stuart@gentoo.org>
+ +webapp-config-1.50.2.ebuild:
+ Version bump; contains bug fixes
*webapp-config-1.50.1 (24 Nov 2005)
diff --git a/app-admin/webapp-config/Manifest b/app-admin/webapp-config/Manifest
index b70f0cfb80ee..ef1f2c349aaa 100644
--- a/app-admin/webapp-config/Manifest
+++ b/app-admin/webapp-config/Manifest
@@ -1,8 +1,10 @@
MD5 4defd726d2b03decc5b7ff21b0aac1a3 metadata.xml 225
-MD5 d34b9555fe932a62679b302c6bc519c2 ChangeLog 14064
+MD5 bc03be5c72ec29191e5ba3a8b35233c1 ChangeLog 14219
MD5 c5a532ad2426cce530602b71c9ee8b4b webapp-config-1.50.ebuild 1477
MD5 2eb01b277c1042ffd36347ee2249e45c webapp-config-1.50.1.ebuild 1479
+MD5 cd6d23474b069c6bb48e257f17553240 webapp-config-1.50.2.ebuild 1478
MD5 90bba75c31e392fd21e084681aeca6ae webapp-config-1.11.ebuild 1408
MD5 6aad9c4cd4548cb948cd4035286d6ac7 files/digest-webapp-config-1.11 70
MD5 e0ab089ccc94a202746357f31ce03c5c files/digest-webapp-config-1.50 70
MD5 d85bb9dd6a593e172a4815e2a751ae6f files/digest-webapp-config-1.50.1 72
+MD5 b24eeb16cb448bd63df034558278cca0 files/digest-webapp-config-1.50.2 71
diff --git a/app-admin/webapp-config/files/digest-webapp-config-1.50.2 b/app-admin/webapp-config/files/digest-webapp-config-1.50.2
new file mode 100644
index 000000000000..1754998f70c0
--- /dev/null
+++ b/app-admin/webapp-config/files/digest-webapp-config-1.50.2
@@ -0,0 +1 @@
+MD5 e81f93f63c82a1452038878560368781 webapp-config-1.50.2.tar.gz 84852
diff --git a/app-admin/webapp-config/webapp-config-1.50.2.ebuild b/app-admin/webapp-config/webapp-config-1.50.2.ebuild
new file mode 100644
index 000000000000..539a2bfc4792
--- /dev/null
+++ b/app-admin/webapp-config/webapp-config-1.50.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/webapp-config/webapp-config-1.50.2.ebuild,v 1.1 2005/12/05 00:02:15 stuart Exp $
+
+inherit eutils distutils
+
+DESCRIPTION="Gentoo's installer for web-based applications"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://dev.gentoo.org/~stuart/webapp-config/${PF}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+S=${WORKDIR}/${PF}
+
+DEPEND=""
+
+src_install() {
+
+ # According to this discussion:
+ # http://mail.python.org/pipermail/distutils-sig/2004-February/003713.html
+ # distutils does not provide for specifying two different script install
+ # locations. Since we only install one script here the following should
+ # be ok
+ distutils_src_install --install-scripts="/usr/sbin"
+
+ dodir /etc/vhosts
+ cp config/webapp-config ${D}/etc/vhosts/
+ keepdir /usr/share/webapps
+ dodoc examples/phpmyadmin-2.5.4-r1.ebuild AUTHORS.txt TODO.txt CHANGES.txt examples/postinstall-en.txt
+ doman doc/webapp-config.5 doc/webapp-config.8 doc/webapp.eclass.5
+ dohtml doc/webapp-config.5.html doc/webapp-config.8.html doc/webapp.eclass.5.html
+}
+
+pkg_postinst() {
+ echo
+ einfo "Now that you have upgraded webapp-config, you **must** update your"
+ einfo "config files in /etc/vhosts/webapp-config before you emerge any"
+ einfo "packages that use webapp-config."
+ echo
+ epause 5
+}