summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-01 21:00:42 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-01 21:00:42 +0000
commita89375f6a07a53f9886c836626722a39cc6f5ad2 (patch)
tree53accfa4077cdfbc5dc78032afdf122ba6f185b5 /app-admin
parentStable on amd64 wrt bug #349258 (diff)
downloadhistorical-a89375f6a07a53f9886c836626722a39cc6f5ad2.tar.gz
historical-a89375f6a07a53f9886c836626722a39cc6f5ad2.tar.bz2
historical-a89375f6a07a53f9886c836626722a39cc6f5ad2.zip
Fix deprecation warning. Use Python 2.
Package-Manager: portage-2.2.0_alpha11_p6/cvs/Linux x86_64
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/conkyforecast/ChangeLog8
-rw-r--r--app-admin/conkyforecast/Manifest4
-rw-r--r--app-admin/conkyforecast/conkyforecast-2.12.ebuild13
3 files changed, 15 insertions, 10 deletions
diff --git a/app-admin/conkyforecast/ChangeLog b/app-admin/conkyforecast/ChangeLog
index 525eb60349bb..d86a34440fa9 100644
--- a/app-admin/conkyforecast/ChangeLog
+++ b/app-admin/conkyforecast/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-admin/conkyforecast
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conkyforecast/ChangeLog,v 1.1 2010/08/24 23:27:59 xmw Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conkyforecast/ChangeLog,v 1.2 2011/01/01 21:00:42 arfrever Exp $
+
+ 01 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ conkyforecast-2.12.ebuild:
+ Fix deprecation warning. Use Python 2.
*conkyforecast-2.12 (24 Aug 2010)
diff --git a/app-admin/conkyforecast/Manifest b/app-admin/conkyforecast/Manifest
index db2d37eb1a44..38299481cabd 100644
--- a/app-admin/conkyforecast/Manifest
+++ b/app-admin/conkyforecast/Manifest
@@ -1,4 +1,4 @@
DIST conkyforecast_2.12.tar.gz 10998488 RMD160 756fbd92a289101166aff4671f1eb916441a6f21 SHA1 9033ab225adee46745e61d966f5044b27a9081d0 SHA256 dd82d294c96cc23281aa74f723fe26269bc6be3843c5386572a945ddb067c37c
-EBUILD conkyforecast-2.12.ebuild 1117 RMD160 07d7ef10f97b529878cc9f84907b4b99e1b6575c SHA1 6e07624be6d6d698102a0a247d77584562606745 SHA256 31bb61e2afaa6e292c6d74963b226d0aabec979a860814a5ccd40e0a06f2cffa
-MISC ChangeLog 498 RMD160 65d3a59d9f8e681fd82067966db74068571e2c38 SHA1 12ab700005b0e327d51da96f0c676f147d549f90 SHA256 8a17afb65d952f15c284d92edc12887ab04a130c9f196182a7325d42b9a45be3
+EBUILD conkyforecast-2.12.ebuild 1140 RMD160 b15fb0dcfb7769922ef59a40cf2210006c5ecbfd SHA1 f517711183df6892dd6c4ab2f32290e2c3c57756 SHA256 fb7e862e95ffe1608292e61cea1ae16fae9684d75c604827974f49b4ab26f2c0
+MISC ChangeLog 647 RMD160 8089c7dfc8c339131d59c41c5a2a618eff15c9f3 SHA1 a452a59572a2a56e280f2b5aa09584caccafbfa7 SHA256 573be967582b5d3d6c50113a405537c929ec2b6727b9b29b1c499556b66c1e2e
MISC metadata.xml 244 RMD160 ba31bc851ce5d8e007b223b4f799d84d4c6699d0 SHA1 2192e855054fb7016488afba3eda6d938fdf925d SHA256 1022f65be1952b5197408dfbf61543b61557601ce3a9f15acabeb3e9d84a0fbe
diff --git a/app-admin/conkyforecast/conkyforecast-2.12.ebuild b/app-admin/conkyforecast/conkyforecast-2.12.ebuild
index a70953b860c4..ee4457e5274e 100644
--- a/app-admin/conkyforecast/conkyforecast-2.12.ebuild
+++ b/app-admin/conkyforecast/conkyforecast-2.12.ebuild
@@ -1,12 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conkyforecast/conkyforecast-2.12.ebuild,v 1.1 2010/08/24 23:27:59 xmw Exp $
-
-EAPI=2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conkyforecast/conkyforecast-2.12.ebuild,v 1.2 2011/01/01 21:00:42 arfrever Exp $
+EAPI="3"
PYTHON_DEPEND="2"
-inherit distutils python
+inherit distutils
DESCRIPTION="Conky weather forecast script with support for language files"
HOMEPAGE="https://launchpad.net/~conkyhardcore"
@@ -21,7 +20,7 @@ RDEPEND="app-admin/conky"
S=${WORKDIR}/src
-pkg_config() {
+pkg_setup() {
python_set_active_version 2
python_pkg_setup
}
@@ -32,6 +31,8 @@ src_prepare() {
}
pkg_postinst() {
+ distutils_pkg_postinst
+
elog "You have to define a partner id and registration code for "
elog "the weather.com xoap. You need to copy the template from"
elog "/usr/share/conkyforecast/conkyForecast.config into you account"