summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2010-05-19 00:12:32 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2010-05-19 00:12:32 +0000
commitc0d1590b60dce690abe3918559a93aac56ae6125 (patch)
tree86fc99ef5699cbdf5687a3412a1e0436dd7cb7cc /app-admin
parentAutomated update of use.local.desc (diff)
downloadhistorical-c0d1590b60dce690abe3918559a93aac56ae6125.tar.gz
historical-c0d1590b60dce690abe3918559a93aac56ae6125.tar.bz2
historical-c0d1590b60dce690abe3918559a93aac56ae6125.zip
Version bumped.
Package-Manager: portage-2.1.8.3/cvs/Linux x86_64
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet/ChangeLog7
-rw-r--r--app-admin/puppet/puppet-0.25.5.ebuild122
2 files changed, 128 insertions, 1 deletions
diff --git a/app-admin/puppet/ChangeLog b/app-admin/puppet/ChangeLog
index a53274afd7a0..38df104153b9 100644
--- a/app-admin/puppet/ChangeLog
+++ b/app-admin/puppet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/puppet
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.57 2010/04/11 12:22:42 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.58 2010/05/19 00:12:32 matsuu Exp $
+
+*puppet-0.25.5 (18 May 2010)
+
+ 18 May 2010; MATSUU Takuto <matsuu@gentoo.org> +puppet-0.25.5.ebuild:
+ Version bumped.
11 Apr 2010; <nixnut@gentoo.org> puppet-0.25.4-r1.ebuild:
ppc stable #306195
diff --git a/app-admin/puppet/puppet-0.25.5.ebuild b/app-admin/puppet/puppet-0.25.5.ebuild
new file mode 100644
index 000000000000..a2f77e3a6bfb
--- /dev/null
+++ b/app-admin/puppet/puppet-0.25.5.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-0.25.5.ebuild,v 1.1 2010/05/19 00:12:32 matsuu Exp $
+
+EAPI="2"
+inherit elisp-common eutils ruby
+
+DESCRIPTION="A system automation and configuration management software"
+HOMEPAGE="http://puppetlabs.com/"
+SRC_URI="http://puppetlabs.com/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="augeas emacs ldap rrdtool shadow vim-syntax"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="dev-lang/ruby[ssl]
+ emacs? ( virtual/emacs )
+ >=dev-ruby/facter-1.5.1"
+RDEPEND="${DEPEND}
+ >=app-portage/eix-0.18.0
+ augeas? ( dev-ruby/ruby-augeas )
+ ldap? ( dev-ruby/ruby-ldap )
+ rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
+ shadow? ( dev-ruby/ruby-shadow )"
+
+USE_RUBY="ruby18"
+
+SITEFILE="50${PN}-mode-gentoo.el"
+
+pkg_setup() {
+ enewgroup puppet
+ enewuser puppet -1 -1 /var/lib/puppet puppet
+}
+
+src_prepare() {
+ # Bug #294304
+ epatch "${FILESDIR}/${PN}-0.25.4-r1-rrd.patch"
+}
+
+src_compile() {
+ if use emacs ; then
+ elisp-compile ext/emacs/puppet-mode.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ DESTDIR="${D}" ruby_einstall "$@" || die
+ DESTDIR="${D}" erubydoc || die
+
+ newinitd "${FILESDIR}"/puppetmaster-0.25.init puppetmaster || die
+ doconfd conf/gentoo/conf.d/puppetmaster || die
+ newinitd "${FILESDIR}"/puppet-0.25.init puppet || die
+ doconfd conf/gentoo/conf.d/puppet || die
+
+ # Initial configuration files
+ keepdir /etc/puppet/manifests || die
+ insinto /etc/puppet
+ doins conf/gentoo/puppet/* || die
+ doins conf/auth.conf || die
+
+ # Location of log and data files
+ keepdir /var/run/puppet || die
+ keepdir /var/log/puppet || die
+ keepdir /var/lib/puppet/ssl || die
+ keepdir /var/lib/puppet/files || die
+ fowners -R puppet:puppet /var/{run,log,lib}/puppet || die
+
+ if use emacs ; then
+ elisp-install ${PN} ext/emacs/puppet-mode.el* || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+
+ if use ldap ; then
+ insinto /etc/openldap/schema; doins ext/ldap/puppet.schema || die
+ fi
+
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax; doins ext/vim/syntax/puppet.vim || die
+ insinto /usr/share/vim/vimfiles/ftdetect; doins ext/vim/ftdetect/puppet.vim || die
+ fi
+
+ # ext and examples files
+ for f in $(find ext examples -type f) ; do
+ docinto "$(dirname ${f})"; dodoc "${f}" || die
+ done
+ docinto conf; dodoc conf/namespaceauth.conf || die
+}
+
+pkg_postinst() {
+ elog
+ elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
+ elog "cause puppet to hang while installing packages."
+ elog
+ elog "Puppet uses eix to get information about currently installed packages,"
+ elog "so please keep the eix metadata cache updated so puppet is able to properly"
+ elog "handle package installations."
+ elog
+ elog "Currently puppet only supports adding and removing services to the default"
+ elog "runlevel, if you want to add/remove a service from another runlevel you may"
+ elog "do so using symlinking."
+ elog
+
+ if [ \
+ -f "${ROOT}/etc/puppet/puppetd.conf" -o \
+ -f "${ROOT}/etc/puppet/puppetmaster.conf" -o \
+ -f "${ROOT}/etc/puppet/puppetca.conf" \
+ ] ; then
+ elog
+ elog "Please remove deprecated config files."
+ elog " /etc/puppet/puppetca.conf"
+ elog " /etc/puppet/puppetd.conf"
+ elog " /etc/puppet/puppetmasterd.conf"
+ elog
+ fi
+
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}