summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRadoslaw Stachowiak <radek@gentoo.org>2006-08-27 16:35:04 +0000
committerRadoslaw Stachowiak <radek@gentoo.org>2006-08-27 16:35:04 +0000
commit0579c543cb868961fe4ab90b6f5d441998ee316f (patch)
treeaa86c2e2826184526d2bbae390c99e25c8c8917e /app-arch/lzma/lzma-4.43.ebuild
parentmodX deps from gmanedit-0.3.3-r4 (diff)
downloadhistorical-0579c543cb868961fe4ab90b6f5d441998ee316f.tar.gz
historical-0579c543cb868961fe4ab90b6f5d441998ee316f.tar.bz2
historical-0579c543cb868961fe4ab90b6f5d441998ee316f.zip
version bump, closes #144671 thanks to Talamona Francesco
Package-Manager: portage-2.1.1_rc1
Diffstat (limited to 'app-arch/lzma/lzma-4.43.ebuild')
-rw-r--r--app-arch/lzma/lzma-4.43.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-arch/lzma/lzma-4.43.ebuild b/app-arch/lzma/lzma-4.43.ebuild
new file mode 100644
index 000000000000..51bc7530f8f0
--- /dev/null
+++ b/app-arch/lzma/lzma-4.43.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lzma/lzma-4.43.ebuild,v 1.1 2006/08/27 16:35:04 radek Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="LZMA Stream Compressor from the SDK"
+HOMEPAGE="http://www.7-zip.org/sdk.html"
+SRC_URI="mirror://sourceforge/sevenzip/${PN}443.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~mips ~ppc-macos ~x86 ~amd64"
+IUSE="doc"
+
+
+src_unpack() {
+ mkdir ${S}
+ cd ${S}
+ unpack ${A}
+}
+
+src_compile() {
+ cd C/7zip/Compress/LZMA_Alone
+ emake -f makefile.gcc \
+ CXX="$(tc-getCXX) ${CXXFLAGS}" \
+ CXX_C="$(tc-getCC) ${CFLAGS}" \
+ || die "Make failed"
+}
+
+src_install() {
+ dobin C/7zip/Compress/LZMA_Alone/lzma
+ if use doc; then
+ dodoc *.txt
+ dohtml *.html
+ fi
+}