summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-06-23 19:29:18 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-06-23 19:29:18 +0000
commitbe3c5c674df22d318ac94c0c2e164fdca40f195e (patch)
treeefd941f30eae671ea24eff826973418b0004fef3 /app-arch/unrar/unrar-3.4.1.ebuild
parentVersion bump and prune older ebuild as source has disappeared upstream. (diff)
downloadhistorical-be3c5c674df22d318ac94c0c2e164fdca40f195e.tar.gz
historical-be3c5c674df22d318ac94c0c2e164fdca40f195e.tar.bz2
historical-be3c5c674df22d318ac94c0c2e164fdca40f195e.zip
Version bump.
Diffstat (limited to 'app-arch/unrar/unrar-3.4.1.ebuild')
-rw-r--r--app-arch/unrar/unrar-3.4.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-arch/unrar/unrar-3.4.1.ebuild b/app-arch/unrar/unrar-3.4.1.ebuild
new file mode 100644
index 000000000000..15c19437174c
--- /dev/null
+++ b/app-arch/unrar/unrar-3.4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unrar/unrar-3.4.1.ebuild,v 1.1 2004/06/23 19:29:18 aliz Exp $
+
+MY_PN=${PN}src
+DESCRIPTION="Uncompress rar files"
+HOMEPAGE="http://www.rarlab.com/rar_add.htm"
+SRC_URI="http://www.rarlab.com/rar/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="unRAR"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64"
+IUSE=""
+
+DEPEND=""
+
+S="${WORKDIR}/unrar"
+
+src_compile() {
+ emake -f makefile.unix CXXFLAGS="$CXXFLAGS" || die "emake failed"
+}
+
+src_install() {
+ dobin unrar || die "dobin failed"
+ dodoc readme.txt
+}