summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-01-30 04:27:49 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-01-30 04:27:49 +0000
commit780567c915749bd681db04c1b5bfd3962e7cb53f (patch)
tree3a214af3c681a8cef84a1d4db34952de2aecb487 /app-arch
parentAdd patch by Andrew Bevitt to fix opengl error #68957 by Stahl Sau. (diff)
downloadhistorical-780567c915749bd681db04c1b5bfd3962e7cb53f.tar.gz
historical-780567c915749bd681db04c1b5bfd3962e7cb53f.tar.bz2
historical-780567c915749bd681db04c1b5bfd3962e7cb53f.zip
Initial commit.
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/hardlink++/ChangeLog11
-rw-r--r--app-arch/hardlink++/Manifest17
-rw-r--r--app-arch/hardlink++/files/digest-hardlink++-0.021
-rw-r--r--app-arch/hardlink++/files/hardlink++-0.02-gcc34-optimize-help.patch48
-rw-r--r--app-arch/hardlink++/files/hardlink++-0.02-sane-makefile.patch13
-rw-r--r--app-arch/hardlink++/hardlink++-0.02.ebuild31
-rw-r--r--app-arch/hardlink++/metadata.xml8
7 files changed, 129 insertions, 0 deletions
diff --git a/app-arch/hardlink++/ChangeLog b/app-arch/hardlink++/ChangeLog
new file mode 100644
index 000000000000..5c30e5ebfbdd
--- /dev/null
+++ b/app-arch/hardlink++/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-arch/hardlink++
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/hardlink++/ChangeLog,v 1.1 2005/01/30 04:27:49 robbat2 Exp $
+
+*hardlink++-0.02 (29 Jan 2005)
+
+ 29 Jan 2005; Robin H. Johnson <robbat2@gentoo.org> +metadata.xml,
+ +files/hardlink++-0.02-gcc34-optimize-help.patch,
+ +files/hardlink++-0.02-sane-makefile.patch, +hardlink++-0.02.ebuild:
+ New package, by Robin H. Johnson <robbat2@gentoo.org>
+
diff --git a/app-arch/hardlink++/Manifest b/app-arch/hardlink++/Manifest
new file mode 100644
index 000000000000..adf843a1b538
--- /dev/null
+++ b/app-arch/hardlink++/Manifest
@@ -0,0 +1,17 @@
+-----BEGIN PGP SIGNED MESSAGE-----
+Hash: SHA1
+
+MD5 67018089868b28ad2fc12d972fae0b04 hardlink++-0.02.ebuild 752
+MD5 c5049f4cd90f23968ab84ee2e1a6f962 ChangeLog 492
+MD5 21cd68602737d7c996bceabf6e62c468 metadata.xml 223
+MD5 84a1c00d3dcb95d9c619a4e68a945f76 files/hardlink++-0.02-gcc34-optimize-help.patch 1877
+MD5 967cd8f8801983fa8efb0b3a9b8a445d files/digest-hardlink++-0.02 63
+MD5 2b45a799b2462929aedb9d5de1125c6a files/hardlink++-0.02-sane-makefile.patch 413
+-----BEGIN PGP SIGNATURE-----
+Version: GnuPG v1.2.6 (GNU/Linux)
+Comment: Robbat2 @ Orbis-Terrarum Networks
+
+iD8DBQFB/GJXPpIsIjIzwiwRAjtLAKDuYTqUuU7jiGz4lWLlejKxA6NYqgCfeqA7
+hYY5bLhzTfYf3dqCS6PMBJ8=
+=K6DH
+-----END PGP SIGNATURE-----
diff --git a/app-arch/hardlink++/files/digest-hardlink++-0.02 b/app-arch/hardlink++/files/digest-hardlink++-0.02
new file mode 100644
index 000000000000..4de1ccec12d0
--- /dev/null
+++ b/app-arch/hardlink++/files/digest-hardlink++-0.02
@@ -0,0 +1 @@
+MD5 edca0c9b726faf50a239c1ca12aa2956 hardlink++-0.02.tgz 12228
diff --git a/app-arch/hardlink++/files/hardlink++-0.02-gcc34-optimize-help.patch b/app-arch/hardlink++/files/hardlink++-0.02-gcc34-optimize-help.patch
new file mode 100644
index 000000000000..5600947f192d
--- /dev/null
+++ b/app-arch/hardlink++/files/hardlink++-0.02-gcc34-optimize-help.patch
@@ -0,0 +1,48 @@
+diff -Nuar hardlink++-0.02.orig/hardlink.cpp hardlink++-0.02/hardlink.cpp
+--- hardlink++-0.02.orig/hardlink.cpp 2003-08-14 19:25:32.000000000 -0700
++++ hardlink++-0.02/hardlink.cpp 2005-01-29 19:57:12.312478520 -0800
+@@ -171,7 +171,7 @@
+
+ // If two files have the same inode and are on the same device then they are
+ // already hardlinked.
+-bool isAlreadyHardlinked(
++inline bool isAlreadyHardlinked(
+ const struct stat & st1, // first file's status
+ const struct stat & st2 ) // second file's status
+ {
+@@ -185,7 +185,7 @@
+
+ // Determine if a file is eligibile for hardlinking. Files will only be
+ // considered for hardlinking if this function returns true.
+-bool eligibleForHardlink(
++inline bool eligibleForHardlink(
+ const struct stat & st1, // first file's status
+ const struct stat & st2 ) // second file's status
+ {
+@@ -203,7 +203,7 @@
+ );
+ }
+
+-bool getFileStatus( const string & filename, struct stat & st )
++inline bool getFileStatus( const string & filename, struct stat & st )
+ {
+ // Get the file status
+ if ( !lstat ( filename.c_str(), &st ) )
+diff -Nuar hardlink++-0.02.orig/hardlink.h hardlink++-0.02/hardlink.h
+--- hardlink++-0.02.orig/hardlink.h 2003-08-14 17:24:59.000000000 -0700
++++ hardlink++-0.02/hardlink.h 2005-01-29 19:55:40.699405824 -0800
+@@ -103,10 +103,10 @@
+ public:
+ // cStats( void ):dircount(0) {}
+
+- void foundDirectory( void ) { ++dircount; }
+- void foundRegularFile( void ) { ++regularfiles; }
+- void didComparison( void ) { ++comparisons; }
+- void foundHardlink( const off_t filesize )
++ inline void foundDirectory( void ) { ++dircount; }
++ inline void foundRegularFile( void ) { ++regularfiles; }
++ inline void didComparison( void ) { ++comparisons; }
++ inline void foundHardlink( const off_t filesize )
+ {
+ ++hardlinked_previously;
+ bytes_saved_previously += filesize;
diff --git a/app-arch/hardlink++/files/hardlink++-0.02-sane-makefile.patch b/app-arch/hardlink++/files/hardlink++-0.02-sane-makefile.patch
new file mode 100644
index 000000000000..b81ac3375b07
--- /dev/null
+++ b/app-arch/hardlink++/files/hardlink++-0.02-sane-makefile.patch
@@ -0,0 +1,13 @@
+diff -Nuar hardlink++-0.02.orig/Makefile hardlink++-0.02/Makefile
+--- hardlink++-0.02.orig/Makefile 2003-08-14 12:59:21.000000000 -0700
++++ hardlink++-0.02/Makefile 2005-01-29 20:00:47.618746992 -0800
+@@ -1,2 +1,7 @@
+-hardlink++: hardlink.cpp hardlink.h
+- g++ -Wall -o hardlink++ hardlink.cpp
++CXX := g++
++CXXFLAGS :=
++BIN := hardlink++
++SRC := hardlink.cpp
++
++$(BIN): $(SRC)
++ $(CXX) -Wall $(CXXFLAGS) -o $@ $^
diff --git a/app-arch/hardlink++/hardlink++-0.02.ebuild b/app-arch/hardlink++/hardlink++-0.02.ebuild
new file mode 100644
index 000000000000..afc3464f730d
--- /dev/null
+++ b/app-arch/hardlink++/hardlink++-0.02.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/hardlink++/hardlink++-0.02.ebuild,v 1.1 2005/01/30 04:27:49 robbat2 Exp $
+
+inherit eutils
+DESCRIPTION="Save disk space by hardlinking identical files."
+HOMEPAGE="http://www.sodarock.com/hardlink/"
+SRC_URI="${HOMEPAGE}/${P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="sys-devel/gcc"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-gcc34-optimize-help.patch || die
+ epatch ${FILESDIR}/${P}-sane-makefile.patch || die
+}
+
+src_compile() {
+ # no configure
+ emake CXXFLAGS="${CXXFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ into /usr
+ dobin hardlink++
+ dodoc README
+}
diff --git a/app-arch/hardlink++/metadata.xml b/app-arch/hardlink++/metadata.xml
new file mode 100644
index 000000000000..5d9f5be9d49d
--- /dev/null
+++ b/app-arch/hardlink++/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>