summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2004-02-06 23:10:06 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2004-02-06 23:10:06 +0000
commita931064ab62d1610033badd09c8928c3d0fd2aff (patch)
tree8ca50534afac9bb5a530926f18cafe80f5fd9aca /app-benchmarks/contest/contest-0.61.ebuild
parentMetadata fix. (diff)
downloadhistorical-a931064ab62d1610033badd09c8928c3d0fd2aff.tar.gz
historical-a931064ab62d1610033badd09c8928c3d0fd2aff.tar.bz2
historical-a931064ab62d1610033badd09c8928c3d0fd2aff.zip
Initial import. Thanks to Diego Garcia (bug #40609).
Diffstat (limited to 'app-benchmarks/contest/contest-0.61.ebuild')
-rw-r--r--app-benchmarks/contest/contest-0.61.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-benchmarks/contest/contest-0.61.ebuild b/app-benchmarks/contest/contest-0.61.ebuild
new file mode 100644
index 000000000000..b4743922fe76
--- /dev/null
+++ b/app-benchmarks/contest/contest-0.61.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/contest/contest-0.61.ebuild,v 1.1 2004/02/06 23:10:06 pyrania Exp $
+
+DESCRIPTION="Test system responsiveness for compare different kernels"
+HOMEPAGE="http://members.optusnet.com.au/ckolivas/contest/"
+SRC_URI="http://members.optusnet.com.au/ckolivas/contest/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+RDEPEND=">=app-benchmarks/dbench-2.0"
+
+src_unpack () {
+ unpack ${A}
+ #Removing -g
+ sed -i "s:-g::" ${S}/Makefile
+ #Adding our cflags
+ sed -i "s:-O2:${CFLAGS}:" ${S}/Makefile
+}
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ into /usr
+ dobin contest
+ doman contest.1
+ dodoc COPYING README
+}