summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-04-06 22:51:08 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-04-06 22:51:08 +0000
commit2506ede831b66765ea4b5565d2324582d17149c0 (patch)
tree69c265e056e6e02469a0b1e77557a879b6f45d81 /app-benchmarks/spew/spew-1.0.8.ebuild
parentVersion bump (diff)
downloadhistorical-2506ede831b66765ea4b5565d2324582d17149c0.tar.gz
historical-2506ede831b66765ea4b5565d2324582d17149c0.tar.bz2
historical-2506ede831b66765ea4b5565d2324582d17149c0.zip
Initial commit.
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'app-benchmarks/spew/spew-1.0.8.ebuild')
-rw-r--r--app-benchmarks/spew/spew-1.0.8.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-benchmarks/spew/spew-1.0.8.ebuild b/app-benchmarks/spew/spew-1.0.8.ebuild
new file mode 100644
index 000000000000..adf4dbd33ec5
--- /dev/null
+++ b/app-benchmarks/spew/spew-1.0.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/spew/spew-1.0.8.ebuild,v 1.1 2011/04/06 22:51:08 blueness Exp $
+
+EAPI=3
+
+inherit autotools eutils
+
+DESCRIPTION="Measures I/O performance and/or generates I/O load"
+HOMEPAGE="http://spew.berlios.de/"
+SRC_URI="ftp://ftp.berlios.de/pub/spew/1.0.8/spew-1.0.8.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="static"
+
+DEPEND="static? ( sys-libs/ncurses[-gpm] dev-libs/popt[static-libs] )
+ !static? ( sys-libs/ncurses dev-libs/popt )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/remove-symlinks-makefile.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static static-link) || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dosym ${PN} /usr/bin/gorge
+ dosym ${PN} /usr/bin/regorge
+ dosym ${PN}.1.bz2 /usr/share/man/man1/gorge.1.bz2
+ dosym ${PN}.1.bz2 /usr/share/man/man1/reorge.1.bz2
+}