summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-06-21 13:20:11 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-06-21 13:20:11 +0000
commit9f610d419d131b4fe6be16a85013d564e0aca94c (patch)
treeee88219a3d0bb70f61cd873d59942d45ed24ef02 /app-benchmarks/spew/spew-1.0.8.ebuild
parentFix for automake-1.13, bug #468070 (diff)
downloadhistorical-9f610d419d131b4fe6be16a85013d564e0aca94c.tar.gz
historical-9f610d419d131b4fe6be16a85013d564e0aca94c.tar.bz2
historical-9f610d419d131b4fe6be16a85013d564e0aca94c.zip
Fix automake-1.13, bug #467550; respect $AR
Package-Manager: portage-2.1.12.2/cvs/Linux x86_64 Manifest-Sign-Key: 0xF52D4BBA
Diffstat (limited to 'app-benchmarks/spew/spew-1.0.8.ebuild')
-rw-r--r--app-benchmarks/spew/spew-1.0.8.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/app-benchmarks/spew/spew-1.0.8.ebuild b/app-benchmarks/spew/spew-1.0.8.ebuild
index 8c32d6eafe3f..d20e38e5c41d 100644
--- a/app-benchmarks/spew/spew-1.0.8.ebuild
+++ b/app-benchmarks/spew/spew-1.0.8.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/spew/spew-1.0.8.ebuild,v 1.6 2012/07/14 12:36:36 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/spew/spew-1.0.8.ebuild,v 1.7 2013/06/21 13:19:42 blueness Exp $
EAPI=4
-inherit autotools eutils
+inherit autotools eutils toolchain-funcs
DESCRIPTION="Measures I/O performance and/or generates I/O load"
HOMEPAGE="http://spew.berlios.de/"
@@ -20,6 +20,7 @@ DEPEND="static? ( sys-libs/ncurses[-gpm] dev-libs/popt[static-libs] )
RDEPEND="${DEPEND}"
src_prepare() {
+ epatch "${FILESDIR}"/fix-automake-1.13.patch
epatch "${FILESDIR}"/remove-symlinks-makefile.patch
eautoreconf
}
@@ -28,6 +29,10 @@ src_configure() {
econf $(use_enable static static-link)
}
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
src_install() {
emake DESTDIR="${D}" install
dosym ${PN} /usr/bin/gorge