summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-30 03:10:52 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-30 03:10:52 +0000
commit746f7b27209053cbacf2851f93505892b2ca329b (patch)
tree0799034568b3cacb719216668faef10d08e61854 /app-cdr/xcdroast
parentChanged mkdir ${D} to dodir ${D} (diff)
downloadhistorical-746f7b27209053cbacf2851f93505892b2ca329b.tar.gz
historical-746f7b27209053cbacf2851f93505892b2ca329b.tar.bz2
historical-746f7b27209053cbacf2851f93505892b2ca329b.zip
Changed src_install () to src_install()
Diffstat (limited to 'app-cdr/xcdroast')
-rw-r--r--app-cdr/xcdroast/xcdroast-0.98_alpha10-r2.ebuild20
1 files changed, 8 insertions, 12 deletions
diff --git a/app-cdr/xcdroast/xcdroast-0.98_alpha10-r2.ebuild b/app-cdr/xcdroast/xcdroast-0.98_alpha10-r2.ebuild
index 4441c038ba22..00735f013bab 100644
--- a/app-cdr/xcdroast/xcdroast-0.98_alpha10-r2.ebuild
+++ b/app-cdr/xcdroast/xcdroast-0.98_alpha10-r2.ebuild
@@ -1,27 +1,26 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/xcdroast-0.98_alpha10-r2.ebuild,v 1.8 2002/11/28 17:10:02 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/xcdroast/xcdroast-0.98_alpha10-r2.ebuild,v 1.9 2002/11/30 03:09:25 vapier Exp $
-S=${WORKDIR}/xcdroast-0.98alpha10
+MY_P="${P/_/}"
+S=${WORKDIR}/${MY_P}
DESCRIPTION="Menu based front-end to mkisofs and cdrecord"
-SRC_URI="http://www.xcdroast.org/download/${PN}-0.98alpha10.tar.gz"
+SRC_URI="http://www.xcdroast.org/download/${MY_P}.tar.gz"
HOMEPAGE="http://www.xcdroast.org/"
+
SLOT="0"
KEYWORDS="x86 ppc"
LICENSE="GPL-2"
# WARNING: cdrtools and mkisofs versions hard coded, see below
-
DEPEND="=x11-libs/gtk+-1.2*
=dev-libs/glib-1.2*
>=media-libs/gdk-pixbuf-0.16.0
>=media-libs/giflib-3.0
<=app-cdr/cdrtools-1.11.33"
-
RDEPEND="<=app-cdr/cdrtools-1.11.33"
-src_compile () {
-
+src_compile() {
# NOTE: This will need to be updated to work with future versions of
# xcdroast (hardcoded versions). The listed dependencies are part
# of the cdrtools package.
@@ -35,8 +34,7 @@ src_compile () {
make PREFIX=/usr CC="gcc ${CFLAGS}" || die
}
-src_install () {
-
+src_install() {
make PREFIX=/usr DESTDIR=${D} install || die
chown root.wheel ${D}/usr/bin/xcdrgtk
dodoc CHANGELOG COPYING DOCUMENTATION FAQ README* TRANSLATION.HOWTO
@@ -45,12 +43,10 @@ src_install () {
mv ${D}/usr/man ${D}/usr/share
}
-pkg_postinst () {
-
+pkg_postinst() {
einfo "Due to limitations in the xcdroast program, the version of cdrtools"
einfo "that it depends on must be hardcoded in the xcdroast program. This"
einfo "means you must have a specific version of cdrtools installed if you"
einfo "plan to use xcdroast. You may need to 'pin' the version of cdrtools"
einfo "in use. (See the portage manual for details)"
-
}