summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-11-30 04:14:30 +0000
committerMike Frysinger <vapier@gentoo.org>2011-11-30 04:14:30 +0000
commitaf118b56cc12286498037c8cac48e68d0b61b908 (patch)
tree71ee140dda17b6ff18cdb50e4d39b66e4c12d1be /app-crypt/gnupg/gnupg-2.0.18.ebuild
parentRespect $(AR), update to EAPI=4, and make sure readline/tcp-wrappers are in R... (diff)
downloadhistorical-af118b56cc12286498037c8cac48e68d0b61b908.tar.gz
historical-af118b56cc12286498037c8cac48e68d0b61b908.tar.bz2
historical-af118b56cc12286498037c8cac48e68d0b61b908.zip
Control readline dep with USE=readline.
Package-Manager: portage-2.2.0_alpha75/cvs/Linux x86_64
Diffstat (limited to 'app-crypt/gnupg/gnupg-2.0.18.ebuild')
-rw-r--r--app-crypt/gnupg/gnupg-2.0.18.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-crypt/gnupg/gnupg-2.0.18.ebuild b/app-crypt/gnupg/gnupg-2.0.18.ebuild
index fa79ed435724..76ef86f142ec 100644
--- a/app-crypt/gnupg/gnupg-2.0.18.ebuild
+++ b/app-crypt/gnupg/gnupg-2.0.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-2.0.18.ebuild,v 1.2 2011/08/19 19:31:56 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-2.0.18.ebuild,v 1.3 2011/11/30 04:14:30 vapier Exp $
EAPI="4"
@@ -14,7 +14,7 @@ SRC_URI="mirror://gnupg/gnupg/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="adns bzip2 doc ldap nls static selinux smartcard usb"
+IUSE="adns bzip2 doc ldap nls readline static selinux smartcard usb"
COMMON_DEPEND_LIBS="
>=dev-libs/libassuan-2
@@ -25,6 +25,7 @@ COMMON_DEPEND_LIBS="
>=net-misc/curl-7.10
adns? ( >=net-libs/adns-1.4 )
bzip2? ( app-arch/bzip2 )
+ readline? ( sys-libs/readline )
smartcard? ( usb? ( virtual/libusb:0 ) )
ldap? ( net-nds/openldap )"
COMMON_DEPEND_BINS="|| ( app-crypt/pinentry app-crypt/pinentry-qt )"
@@ -80,6 +81,7 @@ src_configure() {
$(use_enable !elibc_SunOS symcryptrun) \
$(use_enable nls) \
$(use_enable ldap) \
+ $(use_with readline) \
CC_FOR_BUILD="$(tc-getBUILD_CC)"
}