summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-12-11 13:30:23 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-12-11 13:30:23 +0000
commitd254e46d6b6ba9d309c21220eea8315bc72dda89 (patch)
tree02c0b51c1fbd01cc93d08c159f3153e767679d02 /app-crypt/kencfs/kencfs-1.2-r1.ebuild
parentVersion bump wrt bug #446804. Remove old. (diff)
downloadhistorical-d254e46d6b6ba9d309c21220eea8315bc72dda89.tar.gz
historical-d254e46d6b6ba9d309c21220eea8315bc72dda89.tar.bz2
historical-d254e46d6b6ba9d309c21220eea8315bc72dda89.zip
Add patch by PhobosK <phobosk@fastmail.fm> to support encfs5 volumes, wrt bug #446652. Migrate to EAPI 5, respect DOCDIR & LINGUAS, and fix .desktop validation.
Package-Manager: portage-2.1.11.36/cvs/Linux x86_64 Manifest-Sign-Key: 0x675D0D2C
Diffstat (limited to 'app-crypt/kencfs/kencfs-1.2-r1.ebuild')
-rw-r--r--app-crypt/kencfs/kencfs-1.2-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-crypt/kencfs/kencfs-1.2-r1.ebuild b/app-crypt/kencfs/kencfs-1.2-r1.ebuild
new file mode 100644
index 000000000000..2208bc215511
--- /dev/null
+++ b/app-crypt/kencfs/kencfs-1.2-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/kencfs/kencfs-1.2-r1.ebuild,v 1.1 2012/12/11 13:30:01 kensington Exp $
+
+EAPI=5
+LANGS="it"
+
+inherit qt4-r2
+
+DESCRIPTION="GUI frontend for encfs"
+HOMEPAGE="http://kde-apps.org/content/show.php?content=134003"
+SRC_URI="http://kde-apps.org/CONTENT/content-files/134003-${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="kde-base/kdelibs
+ x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+"
+RDEPEND="${DEPEND}
+ sys-fs/encfs
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1-underlinking.patch"
+ "${FILESDIR}/${P}-desktop.patch"
+ "${FILESDIR}/${P}-encfs5.patch"
+ "${FILESDIR}/${P}-gcc-4.7.patch"
+)
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ sed -i ${PN}.pro -e "/^doc.path =/s/${PN}-1.1/${PF}/" \
+ || die "sed docdir failed"
+
+ if ! use linguas_it ; then
+ sed -i ${PN}.pro -e "s/*.qm//" \
+ || die "sed TRANSLATIONS failed"
+ fi
+}