summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-04-24 17:40:09 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-04-24 17:40:09 +0000
commit60c3a6c83dae0607206417044b8aecfd650c590b (patch)
tree96bec6ce396e4549b79e58106b9c9a88330adcf3 /app-crypt/mcrypt/mcrypt-2.6.4.ebuild
parentnew version, in unstable for testing (diff)
downloadhistorical-60c3a6c83dae0607206417044b8aecfd650c590b.tar.gz
historical-60c3a6c83dae0607206417044b8aecfd650c590b.tar.bz2
historical-60c3a6c83dae0607206417044b8aecfd650c590b.zip
new version, in unstable for testing
Diffstat (limited to 'app-crypt/mcrypt/mcrypt-2.6.4.ebuild')
-rw-r--r--app-crypt/mcrypt/mcrypt-2.6.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-crypt/mcrypt/mcrypt-2.6.4.ebuild b/app-crypt/mcrypt/mcrypt-2.6.4.ebuild
new file mode 100644
index 000000000000..1bb4d5509d61
--- /dev/null
+++ b/app-crypt/mcrypt/mcrypt-2.6.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/mcrypt/mcrypt-2.6.4.ebuild,v 1.1 2003/04/24 17:40:07 robbat2 Exp $
+
+DESCRIPTION="mcrypt is intended to be a replacement of the old unix crypt(1)"
+SRC_URI="ftp://mcrypt.hellug.gr/pub/crypto/mcrypt/${P}.tar.gz"
+HOMEPAGE="http://mcrypt.hellug.gr/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc "
+
+DEPEND=">=dev-libs/libmcrypt-2.5.7
+ >=app-crypt/mhash-0.8.15"
+
+src_compile() {
+ local myconf
+ use nls || myconf="--disable-nls"
+ econf ${myconf} || die "configure error"
+ emake || die "make error"
+}
+
+src_install() {
+ einstall || die "install error"
+ dodoc README NEWS AUTHORS COPYING THANKS TODO
+}