summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2012-05-06 14:13:43 +0000
committerMike Auty <ikelos@gentoo.org>2012-05-06 14:13:43 +0000
commit5c854b5e9e4faf083ed49826f51b3549140a9fef (patch)
tree5b4a40c4f0dfdc183d3084437be06bd130741da1 /app-crypt/ophcrack/ophcrack-3.4.0.ebuild
parentStable for amd64, wrt bug #402287 (diff)
downloadhistorical-5c854b5e9e4faf083ed49826f51b3549140a9fef.tar.gz
historical-5c854b5e9e4faf083ed49826f51b3549140a9fef.tar.bz2
historical-5c854b5e9e4faf083ed49826f51b3549140a9fef.zip
Version bump to 3.4.0, fixes bug 413923.
Package-Manager: portage-2.2.0_alpha101/cvs/Linux x86_64
Diffstat (limited to 'app-crypt/ophcrack/ophcrack-3.4.0.ebuild')
-rw-r--r--app-crypt/ophcrack/ophcrack-3.4.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-crypt/ophcrack/ophcrack-3.4.0.ebuild b/app-crypt/ophcrack/ophcrack-3.4.0.ebuild
new file mode 100644
index 000000000000..8dd1eca13fdd
--- /dev/null
+++ b/app-crypt/ophcrack/ophcrack-3.4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/ophcrack/ophcrack-3.4.0.ebuild,v 1.1 2012/05/06 14:13:43 ikelos Exp $
+
+EAPI="3"
+inherit eutils
+
+DESCRIPTION="A time-memory-trade-off-cracker"
+HOMEPAGE="http://ophcrack.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="qt4 debug +tables"
+
+CDEPEND="dev-libs/openssl
+ net-libs/netwib
+ qt4? ( x11-libs/qt-gui:4 )"
+DEPEND="app-arch/unzip
+ virtual/pkgconfig
+ ${CDEPEND}"
+RDEPEND="tables? ( app-crypt/ophcrack-tables )
+ ${CDEPEND}"
+
+src_configure() {
+
+ local myconf
+
+ myconf="$(use_enable qt4 gui)"
+ myconf="${myconf} $(use_enable debug)"
+
+ econf ${myconf} || die "Failed to compile"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "Installation failed."
+
+ cd "${S}"
+ newicon src/gui/pixmaps/os.xpm ophcrack.xpm
+ make_desktop_entry "${PN}" OphCrack ophcrack
+}