summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe McCann <joem@gentoo.org>2005-05-01 06:55:25 +0000
committerJoe McCann <joem@gentoo.org>2005-05-01 06:55:25 +0000
commit2a206c4b58c97d029f21bfa250a876f9552ded9f (patch)
treef68102af89327d5f603c070a1b6aeb4a67d8898e /app-crypt/seahorse/seahorse-0.7.7.ebuild
parentVersion bump #86358. (diff)
downloadhistorical-2a206c4b58c97d029f21bfa250a876f9552ded9f.tar.gz
historical-2a206c4b58c97d029f21bfa250a876f9552ded9f.tar.bz2
historical-2a206c4b58c97d029f21bfa250a876f9552ded9f.zip
new version, closes 90085
Package-Manager: portage-2.0.51.20-r5
Diffstat (limited to 'app-crypt/seahorse/seahorse-0.7.7.ebuild')
-rw-r--r--app-crypt/seahorse/seahorse-0.7.7.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-crypt/seahorse/seahorse-0.7.7.ebuild b/app-crypt/seahorse/seahorse-0.7.7.ebuild
new file mode 100644
index 000000000000..2dd4082683ce
--- /dev/null
+++ b/app-crypt/seahorse/seahorse-0.7.7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-0.7.7.ebuild,v 1.1 2005/05/01 06:55:25 joem Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="gnome front end to gnupg"
+HOMEPAGE="http://seahorse.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+
+RDEPEND="virtual/x11
+ >=app-crypt/gnupg-1.2.0
+ >=app-crypt/gpgme-1.0.0
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libglade-2
+ >=x11-libs/gtk+-2.4
+ >=gnome-base/eel-2
+ >=gnome-base/gnome-mime-data-2
+ >=gnome-base/libbonobo-2
+ >=gnome-base/libbonoboui-2
+ >=gnome-base/gnome-vfs-2
+ >=app-editors/gedit-2.8.0
+ >=gnome-base/nautilus-2.10
+ dev-util/intltool
+ dev-libs/glib
+ x11-misc/shared-mime-info
+ ldap? ( net-nds/openldap )"
+
+#no ~ppc64 keyword yet >=gnome-base/bonobo-activation-2
+
+DEPEND="${RDEPEND}
+ >=app-text/scrollkeeper-0.3
+ dev-util/pkgconfig"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO THANKS"
+IUSE="doc ldap gnome"
+
+src_compile() {
+ autoconf
+ # note below doesn't work - need to fix
+ append-ldflags -Wl,-z,now
+ export LDFLAGS
+
+ G2CONF=`use_enable ldap`
+ gnome2_src_compile
+}
+
+
+src_install() {
+ gnome2_src_install
+
+ # remove conflicts with x11-misc/shared-mime-info
+ rm -rf ${D}/usr/share/mime/application ${D}/usr/share/mime/magic ${D}/usr/share/mime/globs \
+ ${D}/usr/share/mime/XMLnamespaces
+}