summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2007-04-07 05:29:10 +0000
committerRyan Hill <rhill@gentoo.org>2007-04-07 05:29:10 +0000
commitc7f15cbba956d61c04df8d9aa855032526059df8 (patch)
treebc3ecd5f8097f4f2c56459c5d203b10e5958f58b /app-crypt/wxchecksums/wxchecksums-1.2.2.ebuild
parenttrim trailing newline (diff)
downloadhistorical-c7f15cbba956d61c04df8d9aa855032526059df8.tar.gz
historical-c7f15cbba956d61c04df8d9aa855032526059df8.tar.bz2
historical-c7f15cbba956d61c04df8d9aa855032526059df8.zip
De-crapify:
- move wxGTK from RDEPEND to DEPEND - don't use hardcoded wx-config - don't prestrip binaries Package-Manager: portage-2.1.2.3
Diffstat (limited to 'app-crypt/wxchecksums/wxchecksums-1.2.2.ebuild')
-rw-r--r--app-crypt/wxchecksums/wxchecksums-1.2.2.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/app-crypt/wxchecksums/wxchecksums-1.2.2.ebuild b/app-crypt/wxchecksums/wxchecksums-1.2.2.ebuild
index 235ab41f51e5..f9f8efcc34ad 100644
--- a/app-crypt/wxchecksums/wxchecksums-1.2.2.ebuild
+++ b/app-crypt/wxchecksums/wxchecksums-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/wxchecksums/wxchecksums-1.2.2.ebuild,v 1.5 2007/01/03 03:10:34 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/wxchecksums/wxchecksums-1.2.2.ebuild,v 1.6 2007/04/07 05:29:10 dirtyepic Exp $
inherit eutils wxwidgets
@@ -15,18 +15,20 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="doc"
-RDEPEND=">=x11-libs/wxGTK-2.6.1"
-DEPEND="${RDEPEND}"
+DEPEND="=x11-libs/wxGTK-2.6*"
S="${WORKDIR}/${MY_P}/src"
src_unpack() {
- unpack "${A}"
+ unpack ${A}
cd "${S}"
- # Modify CXXFLAGS
+ export WX_GTK_VER="2.6"
+ need-wxwidgets unicode
+
sed -i \
-e "s:-O2:${CXXFLAGS}:" \
- -e "s:wx-config:wx-config-2.6:" \
+ -e "s:wx-config:${WX_CONFIG}:g" \
+ -e "s:\$(INSTALL) -s:\$(INSTALL):" \
makefile || die "sed makefile failed"
epatch "${FILESDIR}/${PN}-gcc4.patch"
@@ -34,11 +36,6 @@ src_unpack() {
epatch "${FILESDIR}/${P}-wxdebug_build.patch"
}
-pkg_setup() {
- export WX_GTK_VER="2.6"
- need-wxwidgets unicode
-}
-
src_compile() {
emake || die "emake failed"
}