summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-05-11 10:00:17 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-05-11 10:00:17 +0000
commit90e3d09b8d90026a1fce9427256a1df5ffe3ef19 (patch)
treefda78fd8f98c6e24bb0972a6c9aa27f7793529f0 /app-crypt
parentBug #131320 - Use altivec only for single precision - it doesn't work with do... (diff)
downloadhistorical-90e3d09b8d90026a1fce9427256a1df5ffe3ef19.tar.gz
historical-90e3d09b8d90026a1fce9427256a1df5ffe3ef19.tar.bz2
historical-90e3d09b8d90026a1fce9427256a1df5ffe3ef19.zip
revision bumped to force smime usage. This fixes bug #131026
Package-Manager: portage-2.1_pre10-r5
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnupg/ChangeLog9
-rw-r--r--app-crypt/gnupg/files/digest-gnupg-1.9.20-r23
-rw-r--r--app-crypt/gnupg/gnupg-1.9.20-r2.ebuild101
3 files changed, 112 insertions, 1 deletions
diff --git a/app-crypt/gnupg/ChangeLog b/app-crypt/gnupg/ChangeLog
index 43dc4935af34..5d79b269c536 100644
--- a/app-crypt/gnupg/ChangeLog
+++ b/app-crypt/gnupg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/gnupg
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.183 2006/05/10 22:53:07 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.184 2006/05/11 10:00:17 dragonheart Exp $
+
+*gnupg-1.9.20-r2 (11 May 2006)
+
+ 11 May 2006; Daniel Black <dragonheart@gentoo.org> gnupg-1.9.20-r2.ebuild,
+ -gnupg-1.9.20-r1:
+ revision bumped to force smime usage thanks genstef. This fixes bug
+ #131026 thanks Sandro.
10 May 2006; Daniel Black <dragonheart@gentoo.org> gnupg-1.9.20-r1.ebuild:
smime nolonger a USE option - thanks genstef
diff --git a/app-crypt/gnupg/files/digest-gnupg-1.9.20-r2 b/app-crypt/gnupg/files/digest-gnupg-1.9.20-r2
new file mode 100644
index 000000000000..ba3b6d7aa814
--- /dev/null
+++ b/app-crypt/gnupg/files/digest-gnupg-1.9.20-r2
@@ -0,0 +1,3 @@
+MD5 93899203fc0530f03e146d49b65c1e28 gnupg-1.9.20.tar.bz2 1810059
+RMD160 3501de32f1526f64510a77fe3cc0905dd7fc8854 gnupg-1.9.20.tar.bz2 1810059
+SHA256 6272727e5a0e019743e8520a2ff6b42eb4cc89251cb5bbca73dda09cb765487e gnupg-1.9.20.tar.bz2 1810059
diff --git a/app-crypt/gnupg/gnupg-1.9.20-r2.ebuild b/app-crypt/gnupg/gnupg-1.9.20-r2.ebuild
new file mode 100644
index 000000000000..d9d196d7c910
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-1.9.20-r2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.9.20-r2.ebuild,v 1.1 2006/05/11 10:00:17 dragonheart Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="mirror://gnupg/alpha/gnupg/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="1.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="X caps ldap nls smartcard selinux"
+
+COMMON_DEPEND="
+ dev-lang/perl
+ sys-libs/zlib
+ virtual/libc
+ >=dev-libs/pth-1.3.7
+ smartcard? ( >=dev-libs/opensc-0.8.0 )
+ >=dev-libs/libgcrypt-1.1.94
+ >=dev-libs/libksba-0.9.13
+ >=dev-libs/libgpg-error-1.0
+ =dev-libs/libassuan-0.6.10
+ ldap? ( net-nds/openldap )
+ caps? ( sys-libs/libcap )"
+
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="${COMMON_DEPEND}
+ !app-crypt/gpg-agent
+ =app-crypt/gnupg-1.4*
+ X? ( || ( media-gfx/xloadimage media-gfx/xli ) )
+ virtual/mta
+ selinux? ( sec-policy/selinux-gnupg )
+ nls? ( virtual/libintl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if use smartcard && ! built_with_use dev-libs/opensc pcsc-lite ; then
+ sed -i -e 's:OPENSC_LIBS="\$OPENSC_LIBS -lpcsclite -lpthread":OPENSC_LIBS="\$OPENSC_LIBS -lopenct -lpthread":' \
+ acinclude.m4 || die "openct patching failed."
+ ./autogen.sh
+ fi
+ sed -i -e 's/PIC/__PIC__/g' intl/relocatable.c || die "PIC patching failed"
+}
+
+src_compile() {
+ local myconf=""
+
+ if use X; then
+ local viewer
+ if has_version 'media-gfx/xloadimage'; then
+ viewer=/usr/bin/xloadimage
+ else
+ viewer=/usr/bin/xli
+ fi
+ myconf="${myconf} --with-photo-viewer=${viewer}"
+ else
+ myconf="${myconf} --disable-photo-viewers"
+ fi
+
+ use caps || append-ldflags $(bindnow-flags)
+
+ econf \
+ --enable-agent \
+ --enable-symcryptrun \
+ --enable-gpg \
+ --enable-gpgsm \
+ $(use_enable smartcard scdaemon) \
+ $(use_enable nls) \
+ $(use_enable ldap) \
+ $(use_with caps capabilities) \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc ChangeLog NEWS README THANKS TODO VERSION
+
+ if ! use caps; then
+ fperms u+s,go-r /usr/bin/gpg2
+ fperms u+s,go-r /usr/bin/gpg-agent
+ fi
+}
+
+pkg_postinst() {
+ if ! use caps; then
+ einfo "gpg is installed suid root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your"
+ einfo "passphrases, etc. at runtime but may make some sysadmins nervous."
+ fi
+ einfo
+ einfo "See http://www.gentoo.org/doc/en/gnupg-user.xml for documentation on gnupg"
+ einfo
+}