summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2005-01-04 15:57:41 +0000
committerGustavo Felisberto <humpback@gentoo.org>2005-01-04 15:57:41 +0000
commita79b9013a8a3bc8a5b3f7f7c7d7620cf41bf5326 (patch)
tree61117468dc151a5f93b5cc6a18c730523f7030cb /app-crypt
parentMarked stable on x86. (diff)
downloadhistorical-a79b9013a8a3bc8a5b3f7f7c7d7620cf41bf5326.tar.gz
historical-a79b9013a8a3bc8a5b3f7f7c7d7620cf41bf5326.tar.bz2
historical-a79b9013a8a3bc8a5b3f7f7c7d7620cf41bf5326.zip
Fixed no-fixpath
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/qca/ChangeLog8
-rw-r--r--app-crypt/qca/Manifest5
-rw-r--r--app-crypt/qca/files/digest-qca-1.0-r11
-rw-r--r--app-crypt/qca/files/qca-pathfix.patch11
-rw-r--r--app-crypt/qca/qca-1.0-r1.ebuild36
5 files changed, 59 insertions, 2 deletions
diff --git a/app-crypt/qca/ChangeLog b/app-crypt/qca/ChangeLog
index 77b3ce8de3c4..85692fe0484e 100644
--- a/app-crypt/qca/ChangeLog
+++ b/app-crypt/qca/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/qca
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/ChangeLog,v 1.6 2005/01/03 21:43:24 humpback Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/ChangeLog,v 1.7 2005/01/04 15:57:41 humpback Exp $
+
+*qca-1.0-r1 (04 Jan 2005)
+
+ 04 Jan 2005; Gustavo Felisberto <humpback@gentoo.org>;
+ +files/qca-pathfix.patch, +qca-1.0-r1.ebuild:
+ Fixed no-fixpath. Lets see if it solves the Sandbox issues.
03 Jan 2005; Gustavo Felisberto <humpback@gentoo.org>; metadata.xml:
Updated maintainer in metadata.xml
diff --git a/app-crypt/qca/Manifest b/app-crypt/qca/Manifest
index 619f87170d1e..39c0842293df 100644
--- a/app-crypt/qca/Manifest
+++ b/app-crypt/qca/Manifest
@@ -1,4 +1,7 @@
-MD5 d894611f8203a9549b1ccd0ef9e71be3 ChangeLog 826
+MD5 24542aaa997ed4eba6b17d8f13c07299 ChangeLog 1021
MD5 b5393a27b5b3d74649028c3befaf49fe metadata.xml 226
+MD5 172624e6e39acd9c3c01c344ca7ca86e qca-1.0-r1.ebuild 895
MD5 ee67866da62be848ac44be999531aea1 qca-1.0.ebuild 895
MD5 79ff5b8052703491612213e47cdb6947 files/digest-qca-1.0 59
+MD5 79ff5b8052703491612213e47cdb6947 files/digest-qca-1.0-r1 59
+MD5 ee5764e49e4425fb387e29a7d8e2fec0 files/qca-pathfix.patch 267
diff --git a/app-crypt/qca/files/digest-qca-1.0-r1 b/app-crypt/qca/files/digest-qca-1.0-r1
new file mode 100644
index 000000000000..036a79023886
--- /dev/null
+++ b/app-crypt/qca/files/digest-qca-1.0-r1
@@ -0,0 +1 @@
+MD5 ee44022eb0e5b8b5df64c62630f6e6b6 qca-1.0.tar.bz2 30677
diff --git a/app-crypt/qca/files/qca-pathfix.patch b/app-crypt/qca/files/qca-pathfix.patch
new file mode 100644
index 000000000000..6a2a5ac7c615
--- /dev/null
+++ b/app-crypt/qca/files/qca-pathfix.patch
@@ -0,0 +1,11 @@
+--- qca.pro 2003-10-22 15:14:43.000000000 +0100
++++ qca.pro-patched 2005-01-04 15:50:49.928406816 +0000
+@@ -1,7 +1,7 @@
+ # qca qmake profile
+
+ TEMPLATE = lib
+-CONFIG += qt thread release
++CONFIG += qt thread release no_fixpath
+ TARGET = qca
+
+ MOC_DIR = .moc
diff --git a/app-crypt/qca/qca-1.0-r1.ebuild b/app-crypt/qca/qca-1.0-r1.ebuild
new file mode 100644
index 000000000000..f65a47f2c5c4
--- /dev/null
+++ b/app-crypt/qca/qca-1.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca/qca-1.0-r1.ebuild,v 1.1 2005/01/04 15:57:41 humpback Exp $
+
+inherit eutils
+
+DESCRIPTION="Qt Cryptographic Architecture (QCA)"
+HOMEPAGE="http://delta.affinix.com/qca/"
+SRC_URI="http://delta.affinix.com/qca//qca-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~sparc ~ppc ~ia64 ~hppa"
+IUSE=""
+
+DEPEND=">=x11-libs/qt-3.3.0-r1
+ >=dev-libs/openssl-0.9.6i"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/qca-pathfix.patch || die "bad patch"
+}
+
+src_compile() {
+ ./configure --prefix=/usr || die "configure failed"
+ sed -i \
+ -e "/^CFLAGS/s:$: ${CFLAGS}:" \
+ -e "/^CXXFLAGS/s:$: ${CXXFLAGS}:" \
+ Makefile
+ emake || die "emake failed"
+}
+
+src_install() {
+ make INSTALL_ROOT="${D}" install || die "make install failed"
+}