summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOtavio Rodolfo Piske <angusyoung@gentoo.org>2004-09-22 20:08:41 +0000
committerOtavio Rodolfo Piske <angusyoung@gentoo.org>2004-09-22 20:08:41 +0000
commit2e09635f84f36c31221b674367608296d7e6cf78 (patch)
tree27956249756aa8f605de41d913359baaa9f811e1 /app-dicts/babytrans-en/babytrans-en-0.2.ebuild
parentAdded to ~ppc (diff)
downloadhistorical-2e09635f84f36c31221b674367608296d7e6cf78.tar.gz
historical-2e09635f84f36c31221b674367608296d7e6cf78.tar.bz2
historical-2e09635f84f36c31221b674367608296d7e6cf78.zip
Added fetch restrictions to ebuild
Diffstat (limited to 'app-dicts/babytrans-en/babytrans-en-0.2.ebuild')
-rw-r--r--app-dicts/babytrans-en/babytrans-en-0.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-dicts/babytrans-en/babytrans-en-0.2.ebuild b/app-dicts/babytrans-en/babytrans-en-0.2.ebuild
new file mode 100644
index 000000000000..a9e2386bb64c
--- /dev/null
+++ b/app-dicts/babytrans-en/babytrans-en-0.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/babytrans-en/babytrans-en-0.2.ebuild,v 1.1 2004/09/22 20:08:41 angusyoung Exp $
+
+MY_P="english.dic.gz"
+MY_F="english.dic"
+DESCRIPTION="English dictionary for Babytrans"
+HOMEPAGE="ftp://ftp.ac-grenoble.fr/ge/languages/babylon_dict/"
+SRC_URI="${MY_P}"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RESTRICT="fetch"
+
+pkg_nofetch() {
+ einfo "Due to license restrictions that may or may not apply to"
+ einfo "this package, it now has fetch restrictions turned on. This"
+ einfo "means that you must download ${MY_P} file manually from"
+ einfo "${HOMEPAGE} or copy then"
+ einfo "from a windows installation of babylon and put them in "
+ einfo "${DISTDIR}. Finally note that having a license of"
+ einfo "babylon is desired in order to use this package"
+}
+
+src_install() {
+ cd ${WORKDIR}
+ insinto /usr/share/babytrans
+ doins ${MY_F} || die "Unable to install file"
+}