summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-09-11 06:26:53 +0000
committerMamoru Komachi <usata@gentoo.org>2003-09-11 06:26:53 +0000
commitef1cdf11e3ca1febf15a08a71a6de6e22e6f757e (patch)
treee9ed2dba11559784ef2bf3431620a1760abd4481 /app-dicts/canna-2ch/canna-2ch-20030827.ebuild
parentnew ebuild (diff)
downloadhistorical-ef1cdf11e3ca1febf15a08a71a6de6e22e6f757e.tar.gz
historical-ef1cdf11e3ca1febf15a08a71a6de6e22e6f757e.tar.bz2
historical-ef1cdf11e3ca1febf15a08a71a6de6e22e6f757e.zip
new ebuild
Diffstat (limited to 'app-dicts/canna-2ch/canna-2ch-20030827.ebuild')
-rw-r--r--app-dicts/canna-2ch/canna-2ch-20030827.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-dicts/canna-2ch/canna-2ch-20030827.ebuild b/app-dicts/canna-2ch/canna-2ch-20030827.ebuild
new file mode 100644
index 000000000000..727f7bb567b1
--- /dev/null
+++ b/app-dicts/canna-2ch/canna-2ch-20030827.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/canna-2ch/canna-2ch-20030827.ebuild,v 1.1 2003/09/11 06:26:49 usata Exp $
+
+inherit cannadic
+
+IUSE="canna"
+
+DESCRIPTION="Japanese Canna dictionary for 2channelers"
+HOMEPAGE="http://omaemona.sourceforge.net/packages/Canna/"
+SRC_URI="http://dev.gentoo.org/~usata/distfiles/${P}.tar.gz"
+#SRC_URI="http://omaemona.sourceforge.net/packages/Canna/2ch.t"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND=""
+# You cannot use 2ch.cbd as its name. Canna doesn't load dictionaries
+# if the name begins with number. (I don't know why ...)
+CANNADICS="nichan"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+
+ if [ -n "`use canna`" ] ; then
+ mkbindic nichan.ctd || die
+ fi
+}