summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-11-01 11:43:33 +0000
committerPeter Volkov <pva@gentoo.org>2008-11-01 11:43:33 +0000
commitb7af3f78724a253ef0de6e367d1e5d32b11e50d4 (patch)
tree68fb1ad32126df4df75dc39dc3dab75791149d8d /app-dicts/ispell-pt-br/ispell-pt-br-2.4-r3.ebuild
parentCleanup, fixed multilib. (diff)
downloadhistorical-b7af3f78724a253ef0de6e367d1e5d32b11e50d4.tar.gz
historical-b7af3f78724a253ef0de6e367d1e5d32b11e50d4.tar.bz2
historical-b7af3f78724a253ef0de6e367d1e5d32b11e50d4.zip
Cleanup, fixed multilib.
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.26-openvz.git-35f41f1 i686
Diffstat (limited to 'app-dicts/ispell-pt-br/ispell-pt-br-2.4-r3.ebuild')
-rw-r--r--app-dicts/ispell-pt-br/ispell-pt-br-2.4-r3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-dicts/ispell-pt-br/ispell-pt-br-2.4-r3.ebuild b/app-dicts/ispell-pt-br/ispell-pt-br-2.4-r3.ebuild
new file mode 100644
index 000000000000..4b6e40638f66
--- /dev/null
+++ b/app-dicts/ispell-pt-br/ispell-pt-br-2.4-r3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/ispell-pt-br/ispell-pt-br-2.4-r3.ebuild,v 1.1 2008/11/01 11:43:33 pva Exp $
+
+inherit eutils multilib
+
+MY_P="br.ispell-${PV}"
+DESCRIPTION="A Brazilian portuguese dictionary for ispell"
+HOMEPAGE="http://www.ime.usp.br/~ueda/br.ispell"
+SRC_URI="http://www.ime.usp.br/~ueda/br.ispell/${MY_P}.tar.gz
+ mirror://gentoo/${P}-palavras-gentoo.diff.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-text/ispell
+ sys-apps/gawk"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}/${P}-palavras-gentoo.diff"
+}
+
+src_compile() {
+ emake VDIR=/usr/share/dict || die
+ make palavras || die
+ make paradigmas || die
+}
+
+src_install() {
+ dobin conjugue || die
+ doman conjugue.1 || die
+ insinto /usr/share/dict/
+ doins verbos || die
+ insinto "/usr/$(get_libdir)/ispell"
+ newins br.aff pt_BR.aff || die
+ newins br.hash pt_BR.hash || die
+ dodoc README
+}