summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-01-29 14:29:07 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-01-29 14:29:07 +0000
commit183176544a66e89ae1eb75b232bab3696bd941ca (patch)
tree140fd5a5f2c93810bee70ab29219e29e2871227f /app-dicts/kasumi/kasumi-2.4.ebuild
parentVersion bumped. (diff)
downloadhistorical-183176544a66e89ae1eb75b232bab3696bd941ca.tar.gz
historical-183176544a66e89ae1eb75b232bab3696bd941ca.tar.bz2
historical-183176544a66e89ae1eb75b232bab3696bd941ca.zip
Version bumped.
Package-Manager: portage-2.1.6.7/cvs/Linux x86_64
Diffstat (limited to 'app-dicts/kasumi/kasumi-2.4.ebuild')
-rw-r--r--app-dicts/kasumi/kasumi-2.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-dicts/kasumi/kasumi-2.4.ebuild b/app-dicts/kasumi/kasumi-2.4.ebuild
new file mode 100644
index 000000000000..e8a63508aef8
--- /dev/null
+++ b/app-dicts/kasumi/kasumi-2.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/kasumi/kasumi-2.4.ebuild,v 1.1 2009/01/29 14:29:07 matsuu Exp $
+
+DESCRIPTION="Anthy dictionary maintenance tool"
+HOMEPAGE="http://kasumi.sourceforge.jp/"
+SRC_URI="mirror://sourceforge.jp/${PN}/37311/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="nls"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ nls? ( virtual/libintl )
+ virtual/libiconv
+ >=app-i18n/anthy-6131"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ econf $(use_enable nls) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc README ChangeLog AUTHORS
+}