summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2009-11-23 00:22:01 +0000
committerRyan Hill <rhill@gentoo.org>2009-11-23 00:22:01 +0000
commit070a7a2edbb7858f703ab12997c23d9aee4615d1 (patch)
treec1a569fd70a5566639b5cd65c251a2cbb3700f21 /app-dicts/opendict/opendict-0.6.3.ebuild
parentFix bug #286012 also in qemu (diff)
downloadhistorical-070a7a2edbb7858f703ab12997c23d9aee4615d1.tar.gz
historical-070a7a2edbb7858f703ab12997c23d9aee4615d1.tar.bz2
historical-070a7a2edbb7858f703ab12997c23d9aee4615d1.zip
Version bump. Require wxpython:2.8. Keyword ~amd64.
Package-Manager: portage-2.2_rc51/cvs/Linux x86_64
Diffstat (limited to 'app-dicts/opendict/opendict-0.6.3.ebuild')
-rw-r--r--app-dicts/opendict/opendict-0.6.3.ebuild84
1 files changed, 84 insertions, 0 deletions
diff --git a/app-dicts/opendict/opendict-0.6.3.ebuild b/app-dicts/opendict/opendict-0.6.3.ebuild
new file mode 100644
index 000000000000..ac8ad7e7ea5c
--- /dev/null
+++ b/app-dicts/opendict/opendict-0.6.3.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/opendict/opendict-0.6.3.ebuild,v 1.1 2009/11/23 00:22:01 dirtyepic Exp $
+
+EAPI=2
+
+inherit eutils python gnome2
+
+DESCRIPTION="OpenDict is a free cross-platform dictionary program."
+HOMEPAGE="http://opendict.sourceforge.net/"
+SRC_URI="http://opendict.idiles.com/files/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/python-2.3
+ dev-python/wxpython:2.8
+ dev-python/pyxml"
+
+src_prepare() {
+ #epatch "${FILESDIR}/${PN}-0.6.1-desktop.patch"
+ sed -e "s:), '..')):), '../../../../..', 'share', 'opendict')):g" \
+ -i "${S}/lib/info.py"
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ python_version
+ DHOME="/usr/lib/python${PYVER}/site-packages/opendict"
+
+ dodir /usr/share/${PN}/dictionaries/plugins # global dictionary plugins folder
+
+ # Needed by GUI
+ insinto /usr/share/${PN}
+ doins "${S}"/copying.html
+
+ insinto "${DHOME}/lib"
+ doins -r "${S}"/lib/*
+
+ insinto /usr/share/${PN}/pixmaps
+ doins "${S}"/pixmaps/*
+
+ exeinto "${DHOME}"
+ doexe opendict.py
+
+ dosym "${DHOME}/opendict.py" /usr/bin/opendict
+
+ domenu misc/${PN}.desktop
+
+ insinto /usr/share/icons/hicolor/24x24/apps/
+ newins "${S}/pixmaps/icon-24x24.png" opendict.png
+ insinto /usr/share/icons/hicolor/32x32/apps/
+ newins "${S}/pixmaps/icon-32x32.png" opendict.png
+ insinto /usr/share/icons/hicolor/48x48/apps/
+ newins "${S}/pixmaps/icon-48x48.png" opendict.png
+ insinto /usr/share/icons/hicolor/scalable/apps/
+ newins "${S}/pixmaps/SVG/icon-rune.svg" opendict.svg
+
+ doman opendict.1
+ dodoc README.txt TODO.txt doc/Plugin-HOWTO.html
+}
+
+pkg_postinst() {
+ python_mod_optimize \
+ /usr/$(get_libdir)/python${PYVER}/site-packages/opendict
+ gnome2_icon_cache_update
+
+ elog "If you want system-wide plugins, unzip them into"
+ elog "${ROOT}usr/share/${PN}/dictionaries/plugins"
+ elog "Some are available from http://opendict.sourceforge.net/?cid=3"
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+ gnome2_icon_cache_update
+}