summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2006-10-20 15:03:41 +0000
committerOlivier Crête <tester@gentoo.org>2006-10-20 15:03:41 +0000
commit0900e34c0c0b37d50c8ddd2d2682a6378e97263f (patch)
tree0506c70550f323f6f3fa055572eb1bff54edaf7c /app-dicts/verbiste/verbiste-0.1.16.ebuild
parentrevert lib_dir, thanks peper (diff)
downloadhistorical-0900e34c0c0b37d50c8ddd2d2682a6378e97263f.tar.gz
historical-0900e34c0c0b37d50c8ddd2d2682a6378e97263f.tar.bz2
historical-0900e34c0c0b37d50c8ddd2d2682a6378e97263f.zip
Version bump
Package-Manager: portage-2.1.1-r1
Diffstat (limited to 'app-dicts/verbiste/verbiste-0.1.16.ebuild')
-rw-r--r--app-dicts/verbiste/verbiste-0.1.16.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-dicts/verbiste/verbiste-0.1.16.ebuild b/app-dicts/verbiste/verbiste-0.1.16.ebuild
new file mode 100644
index 000000000000..8bf4de82a679
--- /dev/null
+++ b/app-dicts/verbiste/verbiste-0.1.16.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/verbiste/verbiste-0.1.16.ebuild,v 1.1 2006/10/20 15:03:41 tester Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="French conjugation system"
+HOMEPAGE="http://www3.sympatico.ca/sarrazip/dev/verbiste.html"
+SRC_URI="http://www3.sympatico.ca/sarrazip/dev/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="gnome"
+
+RDEPEND=">=dev-libs/libxml2-2.4.0
+ gnome? ( >=gnome-base/gnome-panel-2.0
+ >=gnome-base/libgnomeui-2.0 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+
+#from enlightenment eclass
+gettext_modify() {
+# use nls || return 0
+ cp $(which gettextize) "${T}"/ || die "could not copy gettextize"
+ sed -i \
+ -e 's:read dummy < /dev/tty::' \
+ "${T}"/gettextize
+}
+
+
+src_unpack() {
+ unpack ${A}
+
+ gettext_modify
+
+ cd ${S}
+ "${T}"/gettextize --force --intl --copy
+ AT_M4DIR=macros eautoreconf
+}
+
+
+src_compile() {
+ econf $(use_with gnome) || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "can't install"
+ dodoc AUTHORS ChangeLog HACKING LISEZMOI NEWS README THANKS TODO
+}
+