summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2005-04-02 21:47:51 +0000
committerSteve Arnold <nerdboy@gentoo.org>2005-04-02 21:47:51 +0000
commit8a28b6fb9db4070193cb82c3ec091e9944c4fd2d (patch)
tree2e07d4e72f9ccbaa53a195ed052a9c77db9660c6 /app-doc/doxygen/doxygen-1.4.2.ebuild
parentcleanup, removed old revision with a dependency to oro. marked stable on amd64. (diff)
downloadhistorical-8a28b6fb9db4070193cb82c3ec091e9944c4fd2d.tar.gz
historical-8a28b6fb9db4070193cb82c3ec091e9944c4fd2d.tar.bz2
historical-8a28b6fb9db4070193cb82c3ec091e9944c4fd2d.zip
updated recent ebuilds for bug 80045, bumped and added new version
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'app-doc/doxygen/doxygen-1.4.2.ebuild')
-rw-r--r--app-doc/doxygen/doxygen-1.4.2.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/app-doc/doxygen/doxygen-1.4.2.ebuild b/app-doc/doxygen/doxygen-1.4.2.ebuild
new file mode 100644
index 000000000000..c2610afbcb92
--- /dev/null
+++ b/app-doc/doxygen/doxygen-1.4.2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.2.ebuild,v 1.1 2005/04/02 21:47:51 nerdboy Exp $
+
+inherit eutils
+
+DESCRIPTION="Documentation and analysis tool for C++, C, Java, IDL, PHP and C#"
+HOMEPAGE="http://www.doxygen.org/"
+SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-macos"
+IUSE="doc qt tetex"
+
+RDEPEND="media-gfx/graphviz
+ qt? ( x11-libs/qt )
+ doc? ( tetex? ( virtual/tetex )
+ virtual/ghostscript )"
+DEPEND=">=sys-apps/sed-4
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # use CFLAGS and CXXFLAGS
+ sed -i.orig -e "s:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= ${CFLAGS}:" \
+ -e "s:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= ${CXXFLAGS}:" \
+ tmake/lib/linux-g++/tmake.conf
+ use ppc-macos && epatch ${FILESDIR}/bsd-configure.patch
+}
+
+src_compile() {
+ # set ./configure options (prefix, Qt based wizard, docdir)
+ local confopts="--prefix ${D}/usr"
+ use qt && confopts="${confopts} --with-doxywizard"
+
+ # ./configure and compile
+ ./configure ${confopts} || die '"./configure" failed.'
+ make DESTDIR="${D}" all || die '"make all" failed.'
+
+ # generate html and pdf (if tetex in use) documents.
+ # errors here are not considered fatal, hence the ewarn message
+ # TeX's font caching in /var/cache/fonts causes sandbox warnings,
+ # so we allow it.
+ if use doc; then
+ if use tetex; then
+ addwrite /var/cache/fonts
+ addwrite /usr/share/texmf/fonts/pk
+ addwrite /usr/share/texmf/ls-R
+ make pdf || ewarn '"make docs" failed.'
+ else
+ cp doc/Doxyfile doc/Doxyfile.orig
+ cp doc/Makefile doc/Makefile.orig
+ sed -i.orig -e "s/GENERATE_LATEX = YES/GENERATE_LATEX = NO/" doc/Doxyfile
+ sed -i.orig -e "s/@epstopdf/# @epstopdf/" \
+ -e "s/@cp Makefile.latex/# @cp Makefile.latex/" \
+ -e "s/@sed/# @sed/" doc/Makefile
+ make docs || ewarn '"make docs" failed.'
+ fi
+ fi
+}
+
+src_install() {
+ make install || die '"make install" failed.'
+
+ dodoc INSTALL LANGUAGE.HOWTO LICENSE README VERSION
+
+ # pdf and html manuals
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ if use tetex; then
+ doins latex/doxygen_manual.pdf
+ fi
+ dohtml -r html/*
+ fi
+}
+
+pkg_postinst() {
+
+ ewarn ""
+ einfo "The USE flags qt, doc, and tetex will enable doxywizard, or"
+ einfo "the html and pdf documentation, respectively. For examples"
+ einfo "and other goodies, see the source tarball. For some example"
+ einfo "output, run doxygen on the doxygen source using the Doxyfile"
+ einfo "provided in the top-level source dir."
+ ewarn ""
+}