summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLina Pezzella <j4rg0n@gentoo.org>2005-08-29 18:11:08 +0000
committerLina Pezzella <j4rg0n@gentoo.org>2005-08-29 18:11:08 +0000
commitb2cc800b76cec884e5d3a78176b6fc5f56b226af (patch)
treebc4e0bc9a7c708b7a16a6a810ca64512fe12b8e2 /app-doc/doxygen/doxygen-1.4.2.ebuild
parentStable on sparc wrt #104124 (diff)
downloadhistorical-b2cc800b76cec884e5d3a78176b6fc5f56b226af.tar.gz
historical-b2cc800b76cec884e5d3a78176b6fc5f56b226af.tar.bz2
historical-b2cc800b76cec884e5d3a78176b6fc5f56b226af.zip
Backported ppc-macos qt fix to version 1.4.2. Changed conditional to userland_Darwin where appropriate.
Package-Manager: portage-2.0.51.21
Diffstat (limited to 'app-doc/doxygen/doxygen-1.4.2.ebuild')
-rw-r--r--app-doc/doxygen/doxygen-1.4.2.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/app-doc/doxygen/doxygen-1.4.2.ebuild b/app-doc/doxygen/doxygen-1.4.2.ebuild
index b1f584b96ed7..b5e3f6f75057 100644
--- a/app-doc/doxygen/doxygen-1.4.2.ebuild
+++ b/app-doc/doxygen/doxygen-1.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.2.ebuild,v 1.10 2005/08/23 03:07:59 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.4.2.ebuild,v 1.11 2005/08/29 18:11:08 j4rg0n Exp $
inherit eutils
@@ -26,7 +26,11 @@ src_unpack() {
sed -i.orig -e "s:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= ${CFLAGS}:" \
-e "s:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= ${CXXFLAGS}:" \
tmake/lib/linux-g++/tmake.conf
- use ppc-macos && epatch ${FILESDIR}/bsd-configure.patch
+ if use userland_Darwin; then
+ epatch ${FILESDIR}/bsd-configure.patch
+ [[ "$MACOSX_DEPLOYMENT_TARGET" == "10.4" ]] && sed -i -e 's:-D__FreeBSD__:-D__FreeBSD__=5:' \
+ tmake/lib/macosx-c++/tmake.conf
+ fi
}
src_compile() {