summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWout Mertens <wmertens@gentoo.org>2003-04-26 15:12:25 +0000
committerWout Mertens <wmertens@gentoo.org>2003-04-26 15:12:25 +0000
commit5b10f62d052996da16b1732460feb246903bd623 (patch)
tree711533fa308418037f51586ee12b139667d7ad76 /app-doc/doxygen
parentVersion bump (diff)
downloadhistorical-5b10f62d052996da16b1732460feb246903bd623.tar.gz
historical-5b10f62d052996da16b1732460feb246903bd623.tar.bz2
historical-5b10f62d052996da16b1732460feb246903bd623.zip
Woops
Diffstat (limited to 'app-doc/doxygen')
-rw-r--r--app-doc/doxygen/doxygen-1.3.ebuild62
-rw-r--r--app-doc/doxygen/files/digest-doxygen-1.31
2 files changed, 63 insertions, 0 deletions
diff --git a/app-doc/doxygen/doxygen-1.3.ebuild b/app-doc/doxygen/doxygen-1.3.ebuild
new file mode 100644
index 000000000000..63aec9685f96
--- /dev/null
+++ b/app-doc/doxygen/doxygen-1.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/doxygen/doxygen-1.3.ebuild,v 1.1 2003/04/26 15:12:25 wmertens Exp $
+
+DESCRIPTION="Doxygen is a documentation system for C++, C, Java, IDL (Corba, Microsoft, and KDE-DCOP flavors) and to some extent PHP and C#."
+HOMEPAGE="http://www.doxygen.org"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+IUSE="doc qt"
+RDEPEND="media-gfx/graphviz
+ doc? ( app-text/tetex )
+ qt? ( x11-libs/qt )"
+DEPEND="$RDEPEND"
+
+SRC_URI="ftp://ftp.stack.nl/pub/users/dimitri/${P}.src.tar.gz"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # use CFLAGS and CXXFLAGS
+ sed -i.orig -e "s:^\(TMAKE_CFLAGS_RELEASE\t*\)= .*$:\1= ${CFLAGS}:" \
+ -e "s:^\(TMAKE_CXXFLAGS_RELEASE\t*\)= .*$:\1= ${CXXFLAGS}:" \
+ tmake/lib/linux-g++/tmake.conf
+ # fix doxygen_manual.tex to work with latex-2.x
+ sed -i.orig "s:^\\\setlength\({\\\footrulewidth}\):\\\renewcommand\1:" \
+ doc/doxygen_manual.tex
+}
+
+src_compile() {
+ # set ./configure options (prefix, Qt based wizard, static)
+ local confopts="--prefix ${D}/usr"
+ use qt && confopts="${confopts} --with-doxywizard"
+ #use static && confopts="${confopts} --static"
+
+ # ./configure and compile
+ ./configure ${confopts} || die '"./configure" failed.'
+ emake all || die '"emake all" failed.'
+
+ # generate html and pdf documents.
+ # errors here are not considered fatal, hence the ewarn message
+ # TeX's font caching in /var/cache/fonts causes sandbox warnings,
+ # so we allow it.
+ if use doc; then
+ addwrite /var/cache/fonts
+ make pdf || ewarn '"make docs" failed.'
+ fi
+}
+
+src_install() {
+ make install || die '"make install" failed.'
+
+ dodoc INSTALL LANGUAGE.HOWTO LICENSE README VERSION
+
+ # pdf and html manuals
+ if use doc; then
+ insinto /usr/share/doc/${P}
+ doins latex/doxygen_manual.pdf
+ dohtml -r html/*
+ fi
+}
diff --git a/app-doc/doxygen/files/digest-doxygen-1.3 b/app-doc/doxygen/files/digest-doxygen-1.3
new file mode 100644
index 000000000000..8d65245a9d7b
--- /dev/null
+++ b/app-doc/doxygen/files/digest-doxygen-1.3
@@ -0,0 +1 @@
+MD5 1d08cd47f72341a568216aede9872bbf doxygen-1.3.src.tar.gz 2269864