summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Boeck <hanno@gentoo.org>2003-11-25 22:56:57 +0000
committerHanno Boeck <hanno@gentoo.org>2003-11-25 22:56:57 +0000
commit283cb6cd1e4e34a4325afe9ccd6f9c44db724ac1 (patch)
tree2015cc234ed80bfc718c4032e9cbd4c96ac7babe /app-editors/bluefish/bluefish-0.12.ebuild
parenthppa support (diff)
downloadhistorical-283cb6cd1e4e34a4325afe9ccd6f9c44db724ac1.tar.gz
historical-283cb6cd1e4e34a4325afe9ccd6f9c44db724ac1.tar.bz2
historical-283cb6cd1e4e34a4325afe9ccd6f9c44db724ac1.zip
bluefish version bump
Diffstat (limited to 'app-editors/bluefish/bluefish-0.12.ebuild')
-rw-r--r--app-editors/bluefish/bluefish-0.12.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-editors/bluefish/bluefish-0.12.ebuild b/app-editors/bluefish/bluefish-0.12.ebuild
new file mode 100644
index 000000000000..fe259e84a5f2
--- /dev/null
+++ b/app-editors/bluefish/bluefish-0.12.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/bluefish/bluefish-0.12.ebuild,v 1.1 2003/11/25 22:56:51 hanno Exp $
+
+IUSE="nls spell"
+
+DESCRIPTION="A GTK HTML editor for the experienced web designer or programmer."
+SRC_URI="http://pkedu.fbt.eitn.wau.nl/~olivier/downloads/${P}.tar.bz2"
+HOMEPAGE="http://bluefish.openoffice.nl/"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+SLOT="0"
+
+RDEPEND=">=x11-libs/gtk+-2
+ dev-libs/libpcre
+ spell? ( app-text/aspell )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ # Fix for icon location (bug #31770)
+ sed -i -e 's:ICONDIR/::g' data/bluefish.desktop.in
+
+ local myconf
+ myconf=""
+ # --enable-auto-optimization let bluefish determine optimization
+ # --disable-splash-screen disables the splash screen
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf ${myconf} || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/pixmaps
+ dodir /usr/share/applications
+ dodir /usr/share/gnome/apps
+
+ einstall \
+ datadir=${D}/usr/share \
+ pkgdatadir=${D}/usr/share/bluefish \
+ pixmapsdir=${D}/usr/share/pixmaps \
+ iconpath=${D}/usr/share/pixmaps \
+ gnome2menupath=${D}/usr/share/applications \
+ gnome1menupath=${D}/usr/share/gnome/apps \
+ || die "make install failed"
+}