summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-02-26 04:20:48 +0000
committerMamoru Komachi <usata@gentoo.org>2005-02-26 04:20:48 +0000
commit092a4d12fb5b126f84fad0881a8305c3a80390d1 (patch)
treedee0d9680685d067c9c771a401a1f9b7f2c9b6f7 /app-editors/emacs/emacs-21.3-r2.ebuild
parentpatch from Ron Kracht (bug #83252) (diff)
downloadhistorical-092a4d12fb5b126f84fad0881a8305c3a80390d1.tar.gz
historical-092a4d12fb5b126f84fad0881a8305c3a80390d1.tar.bz2
historical-092a4d12fb5b126f84fad0881a8305c3a80390d1.zip
Updated CVS snapshot for ppc-macos. Removed ebuilds vulnerable to GLSA 200502-20.
Package-Manager: portage-2.0.51.16
Diffstat (limited to 'app-editors/emacs/emacs-21.3-r2.ebuild')
-rw-r--r--app-editors/emacs/emacs-21.3-r2.ebuild94
1 files changed, 0 insertions, 94 deletions
diff --git a/app-editors/emacs/emacs-21.3-r2.ebuild b/app-editors/emacs/emacs-21.3-r2.ebuild
deleted file mode 100644
index 5287d55ade81..000000000000
--- a/app-editors/emacs/emacs-21.3-r2.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.3-r2.ebuild,v 1.18 2005/01/01 13:24:23 eradicator Exp $
-
-inherit flag-o-matic eutils
-
-DESCRIPTION="An incredibly powerful, extensible text editor"
-HOMEPAGE="http://www.gnu.org/software/emacs"
-SRC_URI="mirror://gnu/emacs/${P}.tar.gz
- leim? ( mirror://gnu/emacs/leim-${PV}.tar.gz )"
-
-LICENSE="GPL-2"
-SLOT="21"
-KEYWORDS="x86 ppc sparc alpha amd64 hppa ia64 s390"
-IUSE="X nls motif leim gnome Xaw3d"
-
-RDEPEND="sys-libs/ncurses
- sys-libs/gdbm
- X? ( virtual/x11
- >=media-libs/libungif-4.1.0.1b
- >=media-libs/jpeg-6b-r2
- >=media-libs/tiff-3.5.5-r3
- >=media-libs/libpng-1.2.1
- Xaw3d? ( x11-libs/Xaw3d )
- motif? ( >=x11-libs/openmotif-2.1.30 )
- gnome? ( gnome-base/gnome-desktop )
- )
- nls? ( sys-devel/gettext )"
-DEPEND="${RDEPEND}
- >=sys-devel/autoconf-2.58"
-
-PROVIDE="virtual/emacs virtual/editor"
-SANDBOX_DISABLED="1"
-
-DFILE=emacs.desktop
-
-src_compile() {
-
- # -fstack-protector gets internal compiler error at xterm.c (bug 33265)
- filter-flags -fstack-protector
-
- epatch ${FILESDIR}/${P}-amd64.patch
- epatch ${FILESDIR}/${P}-hppa.patch
-
- export WANT_AUTOCONF=2.1
- autoconf
-
- local myconf
- use nls || myconf="${myconf} --disable-nls"
- if use X ; then
- myconf="${myconf}
- --with-x
- --with-xpm
- --with-jpeg
- --with-tiff
- --with-gif
- --with-png"
- if use Xaw3d ; then
- myconf="${myconf} --with-x-toolkit=athena"
- elif use motif ; then
- myconf="${myconf} --with-x-toolkit=motif"
- else
- # do not build emacs with any toolkit, bug 35300
- myconf="${myconf} --with-x-toolkit=no"
- fi
- else
- myconf="${myconf} --without-x"
- fi
- econf ${myconf} || die
- emake || die
-}
-
-src_install() {
- einstall || die
- einfo "Fixing info documentation..."
- rm -f ${D}/usr/share/info/dir
- for i in ${D}/usr/share/info/*
- do
- mv ${i%.info} $i.info
- done
-
- einfo "Fixing permissions..."
- find ${D} -perm 664 |xargs chmod 644
- find ${D} -type d |xargs chmod 755
-
- dodoc BUGS ChangeLog README
-
- keepdir /usr/share/emacs/${PV}/leim
-
- if use gnome ; then
- insinto /usr/share/gnome/apps/Application
- doins ${FILESDIR}/${DFILE}
- fi
-}