summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-04-12 21:05:14 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-04-12 21:05:14 +0000
commit4c783063193b93d7cee0e559f9f58a4c1948c144 (patch)
treea60c5b696e1d21977c48f8d642d703451f5409a7 /app-editors/emacs
parentlibpng update (diff)
downloadhistorical-4c783063193b93d7cee0e559f9f58a4c1948c144.tar.gz
historical-4c783063193b93d7cee0e559f9f58a4c1948c144.tar.bz2
historical-4c783063193b93d7cee0e559f9f58a4c1948c144.zip
libpng update
Diffstat (limited to 'app-editors/emacs')
-rw-r--r--app-editors/emacs/ChangeLog7
-rw-r--r--app-editors/emacs/emacs-21.1-r4.ebuild82
-rw-r--r--app-editors/emacs/files/digest-emacs-21.1-r41
3 files changed, 89 insertions, 1 deletions
diff --git a/app-editors/emacs/ChangeLog b/app-editors/emacs/ChangeLog
index f9c5b022257c..a2c12e6d47c7 100644
--- a/app-editors/emacs/ChangeLog
+++ b/app-editors/emacs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/emacs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.1 2002/02/01 21:53:01 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/ChangeLog,v 1.2 2002/04/12 21:05:14 spider Exp $
+
+
+*emacs-21.1-r4 (11 Apr 2002)
+ 11 Apr 2002; Spider <spider@gentoo.org>
+ Update libpng dependency
*emacs-21.1-r3 (1 Feb 2002)
diff --git a/app-editors/emacs/emacs-21.1-r4.ebuild b/app-editors/emacs/emacs-21.1-r4.ebuild
new file mode 100644
index 000000000000..c2775d9a3449
--- /dev/null
+++ b/app-editors/emacs/emacs-21.1-r4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: System Team <system@gentoo.org>
+# Author: Mikael Hallendal <micke@hallendal.net>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs/emacs-21.1-r4.ebuild,v 1.1 2002/04/12 21:05:14 spider Exp $
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An incredibly powerful, extensible text editor"
+SRC_URI="ftp://ftp.codefactory.se/pub/gnu/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/emacs"
+
+# Never use the sandbox, it causes Emacs to segfault on startup
+SANDBOX_DISABLED="1"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ sys-libs/gdbm
+ X? ( virtual/x11
+ >=media-libs/libungif-4.1.0
+ >=media-libs/jpeg-6b-r2
+ >=media-libs/tiff-3.5.5-r3
+ >=media-libs/libpng-1.2.1 )
+ motif? ( >=x11-libs/openmotif-2.1.30 )
+ nls? ( >=sys-devel/gettext-0.10.35 )"
+
+
+PROVIDE="virtual/emacs"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ] ; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ if [ "`use X`" ] ; then
+ myconf="${myconf} \
+ --with-x \
+ --with-xpm \
+ --with-jpeg \
+ --with-tiff \
+ --with-gif \
+ --with-png"
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+ if [ "`use motif`" ] ; then
+ myconf="${myconf} --with-x-toolkit=motif"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --libexecdir=/usr/lib \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install () {
+ make prefix=${D}/usr \
+ libexecdir=${D}/usr/lib \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ cd ${D}/usr/share/info
+ rm dir
+
+ for i in *
+ do
+ mv ${i%.info} $i.info
+ done
+
+ dodoc BUGS ChangeLog README
+
+ # Gives a warning if it doesn't exist
+ dodir /usr/share/emacs/21.1/leim
+ touch ${D}/usr/share/emacs/21.1/leim/.keep
+}
diff --git a/app-editors/emacs/files/digest-emacs-21.1-r4 b/app-editors/emacs/files/digest-emacs-21.1-r4
new file mode 100644
index 000000000000..1843fde85cb6
--- /dev/null
+++ b/app-editors/emacs/files/digest-emacs-21.1-r4
@@ -0,0 +1 @@
+MD5 3e0de8cf3ffe92e04c748842f7c64e62 emacs-21.1.tar.gz 20321444