summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-03-07 00:11:05 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-03-07 00:11:05 +0000
commita15492e4dc20b37ca28c5d6ec71f8bd10a3a9acb (patch)
tree140b507f1df0f7e4c16085ea2f6940a6dd8a700c /app-editors/gphpedit/gphpedit-0.9.91.ebuild
parentFix slot-deps on gtk+ and other libs (diff)
downloadhistorical-a15492e4dc20b37ca28c5d6ec71f8bd10a3a9acb.tar.gz
historical-a15492e4dc20b37ca28c5d6ec71f8bd10a3a9acb.tar.bz2
historical-a15492e4dc20b37ca28c5d6ec71f8bd10a3a9acb.zip
Fix slot-deps on gtk+ and other libs
Package-Manager: portage-2.1.9.42/cvs/Linux x86_64
Diffstat (limited to 'app-editors/gphpedit/gphpedit-0.9.91.ebuild')
-rw-r--r--app-editors/gphpedit/gphpedit-0.9.91.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/app-editors/gphpedit/gphpedit-0.9.91.ebuild b/app-editors/gphpedit/gphpedit-0.9.91.ebuild
index 25b07962df43..5775e70c1e5d 100644
--- a/app-editors/gphpedit/gphpedit-0.9.91.ebuild
+++ b/app-editors/gphpedit/gphpedit-0.9.91.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gphpedit/gphpedit-0.9.91.ebuild,v 1.5 2008/03/27 21:29:12 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gphpedit/gphpedit-0.9.91.ebuild,v 1.6 2011/03/07 00:11:05 nirbheek Exp $
+
+EAPI="2"
inherit gnome2 eutils
@@ -13,11 +15,11 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-RDEPEND=">=x11-libs/gtk+-2.0
- >=dev-libs/glib-2.0
+RDEPEND=">=x11-libs/gtk+-2.0:2
+ >=dev-libs/glib-2.0:2
>=gnome-base/libgnomeui-2.0
- >=gnome-base/gnome-vfs-2.0
- =gnome-extra/gtkhtml-2*"
+ >=gnome-base/gnome-vfs-2.0:2
+ gnome-extra/gtkhtml:2"
DEPEND="${RDEPEND}
sys-devel/gettext
@@ -28,8 +30,8 @@ DOCS="AUTHORS ChangeLog README TODO"
# Parallel build unhappy (bug #145351)
MAKEOPTS="${MAKEOPTS} -j1"
-src_unpack() {
- gnome2_src_unpack
-
+src_prepare() {
epatch "${FILESDIR}"/${PN}-0.9.91-empty-apply-prefs.patch
+
+ gnome2_src_prepare
}