summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2010-12-08 20:21:02 +0000
committerJim Ramsay <lack@gentoo.org>2010-12-08 20:21:02 +0000
commitfe078aee11024d2a7d8ebd42b54a06c9518fc6d9 (patch)
tree29c7edede304a0b1e8a39b7ea0e011b70be1e76d /app-editors/gvim/gvim-7.3.75.ebuild
parentNeeds gnome-panel with bonobo support. (diff)
downloadhistorical-fe078aee11024d2a7d8ebd42b54a06c9518fc6d9.tar.gz
historical-fe078aee11024d2a7d8ebd42b54a06c9518fc6d9.tar.bz2
historical-fe078aee11024d2a7d8ebd42b54a06c9518fc6d9.zip
Version bump: 7.3.75 is released
Package-Manager: portage-2.1.9.14/cvs/Linux i686
Diffstat (limited to 'app-editors/gvim/gvim-7.3.75.ebuild')
-rw-r--r--app-editors/gvim/gvim-7.3.75.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-editors/gvim/gvim-7.3.75.ebuild b/app-editors/gvim/gvim-7.3.75.ebuild
new file mode 100644
index 000000000000..2412567eea3f
--- /dev/null
+++ b/app-editors/gvim/gvim-7.3.75.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gvim/gvim-7.3.75.ebuild,v 1.1 2010/12/08 20:21:02 lack Exp $
+
+EAPI=3
+VIM_VERSION="7.3"
+inherit vim
+
+VIM_ORG_PATCHES="vim-patches-${PV}.tar.bz2"
+GVIMRC_FILE_SUFFIX="-r1"
+GVIM_DESKTOP_SUFFIX="-r2"
+
+SRC_URI="ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S="${WORKDIR}/vim${VIM_VERSION/.}"
+DESCRIPTION="GUI version of the Vim text editor"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ vim_src_prepare
+
+ epatch "${FILESDIR}"/${PN}-7.1.285-darwin-x11link.patch
+ if [[ ${CHOST} == *-interix* ]]; then
+ epatch "${FILESDIR}"/${PN}-7.1-interix-link.patch
+ epatch "${FILESDIR}"/${PN}-7.1.319-interix-cflags.patch
+ fi
+}