summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-02-13 10:14:10 +0000
committerPacho Ramos <pacho@gentoo.org>2012-02-13 10:14:10 +0000
commitc09675990fabc172b04cdb4514e268ecfb8de77d (patch)
tree82706b5be4546b879152299226f09dbc5e5a912c /app-editors/latexila/latexila-2.2.3.ebuild
parentppc64 stable wrt #391757 (diff)
downloadhistorical-c09675990fabc172b04cdb4514e268ecfb8de77d.tar.gz
historical-c09675990fabc172b04cdb4514e268ecfb8de77d.tar.bz2
historical-c09675990fabc172b04cdb4514e268ecfb8de77d.zip
Version bump.
Package-Manager: portage-2.1.10.46/cvs/Linux x86_64
Diffstat (limited to 'app-editors/latexila/latexila-2.2.3.ebuild')
-rw-r--r--app-editors/latexila/latexila-2.2.3.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/app-editors/latexila/latexila-2.2.3.ebuild b/app-editors/latexila/latexila-2.2.3.ebuild
new file mode 100644
index 000000000000..8bbe6ff9ebb6
--- /dev/null
+++ b/app-editors/latexila/latexila-2.2.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/latexila/latexila-2.2.3.ebuild,v 1.1 2012/02/13 10:14:10 pacho Exp $
+
+EAPI="4"
+CMAKE_MIN_VERSION="2.6.4"
+CMAKE_IN_SOURCE_BUILD="yes" # for gnome2.eclass compat
+GCONF_DEBUG="no"
+
+inherit cmake-utils gnome2
+
+DESCRIPTION="Integrated LaTeX environment for GNOME"
+HOMEPAGE="http://projects.gnome.org/latexila/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome +latexmk rubber"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.28:2
+ dev-libs/libgee:0
+ dev-libs/libunique:1
+ >=x11-libs/gtk+-2.16:2
+ >=x11-libs/gtksourceview-2.10:2.0
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libX11
+ x11-libs/pango
+ gnome? ( gnome-base/gsettings-desktop-schemas )
+"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ x11-themes/hicolor-icon-theme
+ latexmk? ( dev-tex/latexmk )
+ rubber? ( dev-tex/rubber )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/itstool
+ dev-util/pkgconfig
+ sys-devel/gettext
+"
+
+pkg_setup() {
+ DOCS="AUTHORS HACKING NEWS README TODO"
+}
+
+src_prepare() {
+ if [[ -n ${LINGUAS+set} ]]; then
+ # LINGUAS is set, let's try to respect it.
+ pushd po > /dev/null
+ local po_file
+ for po_file in *.po; do
+ has "${po_file%.po}" ${LINGUAS} || rm -v "${po_file}"
+ done
+ popd > /dev/null
+ fi
+}
+
+src_configure() {
+ local mycmakeargs="
+ $(cmake-utils_use_with gnome GNOME)
+ -DCOMPILE_SCHEMA=OFF"
+ cmake-utils_src_configure
+}