summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-05-11 09:38:19 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-05-11 09:38:19 +0000
commitfdea4eb5c450309e86cc2bb0db833b6d131f73fc (patch)
treeba081e9d0abde138ce490893b24e908299a20f36 /app-editors/qemacs/qemacs-0.3.1.ebuild
parentadded some more docs (diff)
downloadhistorical-fdea4eb5c450309e86cc2bb0db833b6d131f73fc.tar.gz
historical-fdea4eb5c450309e86cc2bb0db833b6d131f73fc.tar.bz2
historical-fdea4eb5c450309e86cc2bb0db833b6d131f73fc.zip
new ebuild
Diffstat (limited to 'app-editors/qemacs/qemacs-0.3.1.ebuild')
-rw-r--r--app-editors/qemacs/qemacs-0.3.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-editors/qemacs/qemacs-0.3.1.ebuild b/app-editors/qemacs/qemacs-0.3.1.ebuild
new file mode 100644
index 000000000000..6e915e2e140e
--- /dev/null
+++ b/app-editors/qemacs/qemacs-0.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1.ebuild,v 1.1 2003/05/11 09:38:19 mkennedy Exp $
+
+DESCRIPTION="QEmacs (for Quick Emacs) is a very small but powerful UNIX editor."
+HOMEPAGE="http://fabrice.bellard.free.fr/qemacs/"
+SRC_URI="http://fabrice.bellard.free.fr/qemacs/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="X? ( virtual/x11 )
+ png? ( =media-libs/libpng-1.2* )"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} && patch -p1 <${FILESDIR}/qemacs-Makefile-gentoo.patch || die
+}
+
+src_compile() {
+ local myconf
+ use X && myconf="--enable-x11" || myconf="--disable-x11"
+ use png && myconf="${myconf} --enable-png" || myconf="${myconf} --disable-png"
+ ./configure ${myconf}
+ emake || die
+}
+
+src_install() {
+ dodir /usr/bin
+ make prefix=${D}/usr \
+ install || die
+ doman qe.1
+ dodoc COPYING Changelog README TODO VERSION
+ dohtml *.html
+}