summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Nazaroff <naz@gentoo.org>2002-06-22 16:38:30 +0000
committerMichael Nazaroff <naz@gentoo.org>2002-06-22 16:38:30 +0000
commit1ae4127799e7d6bde72771e7b2198e5713a40c81 (patch)
tree36111bac97405d79d8285e61e6bad91b1a6958bd /app-editors/vi
parentNew verison, it works too:) (diff)
downloadhistorical-1ae4127799e7d6bde72771e7b2198e5713a40c81.tar.gz
historical-1ae4127799e7d6bde72771e7b2198e5713a40c81.tar.bz2
historical-1ae4127799e7d6bde72771e7b2198e5713a40c81.zip
Added addpredict line to vi to fix sandbox violoation
Diffstat (limited to 'app-editors/vi')
-rw-r--r--app-editors/vi/files/digest-vi-3.7-r11
-rw-r--r--app-editors/vi/vi-3.7-r1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-editors/vi/files/digest-vi-3.7-r1 b/app-editors/vi/files/digest-vi-3.7-r1
new file mode 100644
index 000000000000..7e51cfd075bf
--- /dev/null
+++ b/app-editors/vi/files/digest-vi-3.7-r1
@@ -0,0 +1 @@
+MD5 544e5014f8fe8674ec3bcedd30815582 ex-020403.tar.gz 216587
diff --git a/app-editors/vi/vi-3.7-r1.ebuild b/app-editors/vi/vi-3.7-r1.ebuild
new file mode 100644
index 000000000000..8f5718fafaec
--- /dev/null
+++ b/app-editors/vi/vi-3.7-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author: Spider <spider@gentoo.org>
+# Maintainer: Spider <spider@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vi/vi-3.7-r1.ebuild,v 1.1 2002/06/22 16:38:30 naz Exp $
+
+MY_P=ex-020403
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="The original VI package"
+SRC_URI="http://download.berlios.de/ex-vi/${MY_P}.tar.gz"
+HOMEPAGE="http://ex-vi.berlios.de/"
+LICENSE="Caldera"
+DEPEND="virtual/glibc sys-libs/ncurses"
+SLOT="0"
+RDEPEND=$DEPEND
+
+src_compile() {
+
+ addpredict /dev/ptys/*
+
+ make DESTDIR=/usr \
+ TERMLIB=ncurses \
+ PRESERVEDIR=/var/preserve || die "failed compilation"
+}
+
+src_install () {
+ dodir /var/preserve
+ dodir /usr/share/man
+ make INSTALL=/usr/bin/install \
+ DESTDIR=${D}/usr \
+ MANDIR=/share/man \
+ PRESERVEDIR=${D}/var/preserve \
+ TERMLIB=ncurses \
+ install || die
+ dodoc Changes LICENSE README TODO
+}