summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2002-12-22 18:34:03 +0000
committerMichael Cummings <mcummings@gentoo.org>2002-12-22 18:34:03 +0000
commitf7392c9bc83efa9e59bafc7773fe459ddf4664e0 (patch)
tree105da316d09b7a9ddf9eefcec0c26a165fc3a727 /app-editors/xvile/xvile-9.3h.ebuild
parentnew version; obey USE="-ssl" (diff)
downloadhistorical-f7392c9bc83efa9e59bafc7773fe459ddf4664e0.tar.gz
historical-f7392c9bc83efa9e59bafc7773fe459ddf4664e0.tar.bz2
historical-f7392c9bc83efa9e59bafc7773fe459ddf4664e0.zip
bug 12469 gets all the thanks - compiles with perl 5.8
Diffstat (limited to 'app-editors/xvile/xvile-9.3h.ebuild')
-rw-r--r--app-editors/xvile/xvile-9.3h.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/app-editors/xvile/xvile-9.3h.ebuild b/app-editors/xvile/xvile-9.3h.ebuild
new file mode 100644
index 000000000000..5b7dec63aad5
--- /dev/null
+++ b/app-editors/xvile/xvile-9.3h.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/xvile/xvile-9.3h.ebuild,v 1.1 2002/12/22 18:34:03 mcummings Exp $
+
+IUSE="perl"
+
+S=${WORKDIR}/vile-9.3
+DESCRIPTION="VI Like Emacs -- yet another full-featured vi clone"
+SRC_URI="ftp://ftp.phred.org/pub/vile/vile-9.3.tgz
+ ftp://ftp.phred.org/pub/vile/patches/vile-9.3a.patch.gz
+ ftp://ftp.phred.org/pub/vile/patches/vile-9.3b.patch.gz
+ ftp://ftp.phred.org/pub/vile/patches/vile-9.3c.patch.gz
+ ftp://ftp.phred.org/pub/vile/patches/vile-9.3d.patch.gz
+ ftp://ftp.phred.org/pub/vile/patches/vile-9.3e.patch.gz
+ ftp://ftp.phred.org/pub/vile/patches/vile-9.3f.patch.gz
+ ftp://ftp.phred.org/pub/vile/patches/vile-9.3g.patch.gz
+ ftp://ftp.phred.org/pub/vile/patches/vile-9.3h.patch.gz"
+
+HOMEPAGE="http://www.clark.net/pub/dickey/vile/vile.html"
+
+DEPEND="virtual/glibc
+ sys-devel/flex
+ virtual/x11
+ =app-editors/vile-9.3h"
+
+RDEPEND="perl? ( sys-devel/perl )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+src_unpack() {
+ unpack vile-9.3.tgz
+
+ cd ${S}
+ local i
+ for i in a b c d e f g h
+ do
+ gunzip -c ${DISTDIR}/vile-9.3$i.patch.gz | patch -p1
+ done
+}
+
+src_compile() {
+ local myconf
+ use perl && myconf="--with-perl"
+
+ ./configure --prefix=/usr --host=${CHOST} \
+ --mandir=/usr/share/man \
+ --with-x \
+ $myconf || die
+
+ emake || die
+}
+
+src_install () {
+ dobin xvile
+ make DESTDIR=${D} install || die
+ dodoc CHANGES* COPYING MANIFEST INSTALL README* doc/*
+}